Release Specific Support

Supported Platforms Guide P-Foundation

This guide lists the platforms supported by the Synopsys P-Foundation Releases 2019.03, 2019.06, 2019.09.  A platform consists of the computer architecture and the operating system version. Not all Synopsys products are available on every platform listed below. For an exact listing of platform availability for Synopsys products you have purchased, consult the Synopsys Solvnet Download: https://solvnet.synopsys.com/DownloadCenter/dc/product.jsp.

Use the following index to jump directly to the P-Foundation Operating System and Patch recommendations:

x86_64 Linux 64-bit
x86 Microsoft Windows

Synopsys builds its products on selected versions’ of each operating system. Operating system vendors guarantee that applications compiled on a lower minor version of an operating system will be binary compatible with higher minor versions of the same operating system. This means that an application supported on OS version X.Y will run on OS version X.Z. For example, a tool supported on RHEL 6.6 will run on RHEL 6.7. Synopsys relies on the OS vendor's binary compatibility claim and supports running higher minor versions. Synopsys also relies on the vendor’s binary compatibility claim on support across major versions. For example, a tool supported on RHEL 6.x will run on RHEL 7.x.

Synopsys products are tested on the following operating systems with the listed recommended patches installed.

x86_64 Linux 64-bit – CentOS

  • Compiler
    GCC 6.2.0

Window Manager

  • GNOME Native Version Distributed with CentOS

Tested Configurations

CentOS release 6.6

  • Recommended patches
    • None

CentOS release 6.7

  • Recommended patches
    • None

CentOS release 6.8

  • Recommended patches
    • None

CentOS release 7.1.1503

  • Recommended patches
    • None

CentOS release 7.3.1611

  • Recommended patches
    • None

x86_64 Linux 64-bit – RedHat Enterprise Linux 

  • Windows Manager
    GNOME Native Version Distributed with RedHat Enterprise Linux

Tested Configurations

Red Hat Enterprise Linux 6.6

  • Recommended Patches
    • CVE-2016-7117 Security Patch - Critical Security Patch for 'use-after-free' vulnerability
      • kernel-2.6.32-642.13.1.el6.x86_64.rpm
      • kernel-firmware-2.6.32-642.13.1.el6.noarch.rpm
    • GHOST Security Patches - Critical Security Patch for gethostbyname () vulnerability
      • glibc-2.12-1.149.el6_6.5.i686.rpm
      • glibc-2.12-1.149.el6_6.5.x86_64.rpm
      • glibc-common-2.12-1.149.el6_6.5.x86_64.rpm
      • nscd-2.12-1.149.el6_6.5.x86_64.rpm
    • Open SSL Security Patches - Critical Security Patch for "DOS" and "POODLE" attacks
      • openssl-1.0.1e-30.el6_6.5.i686.rpm
      • openssl-1.0.1e-30.el6_6.5.x86_64.rpm

Red Hat Enterprise Linux 6.7

  • Recommended Patches
    • CVE-2016-7117 Security Patch - Critical Security Patch for 'use-after-free' vulnerability
      • kernel-2.6.32-642.13.1.el6.x86_64.rpm

Red Hat Enterprise Linux 6.8

  • Recommended Patches
    • None

Red Hat Enterprise Linux 7.1

  • Recommended Patches
    • CVE-2016-7117 Security Patch - ​Critical Security Patch for 'use-after-free' vulnerability CVE-2016-7117 Security Patch
      • kernel-3.10.0-514.6.1.el7.x86_64.rpm

Red Hat Enterprise Linux 7.2

  • Recommended Patches
    • CVE-2016-7117 Security Patch - ​Critical Security Patch for 'use-after-free' vulnerability CVE-2016-7117 Security Patch
      • kernel-3.10.0-514.6.1.el7.x86_64.rpm

Red Hat Enterprise Linux 7.3

  • Recommended Patches
    • RHSA-2017:1308 Security Patch - ​SNPS IT Recommended Security Patch
      • kernel-3.10.0-514.21.1.el7.x86_64.rpm

Red Hat Enterprise Linux 7.4

  • Recommended Patches
    • None

Red Hat Enterprise Linux 7.5

  • Recommended Patches
    • None

x86_64 Linux 64-bit - SUSE Linux Enterprise Server

  • Windows Manager
    Native version distributed with SUSE Linux Enterprise Server

Tested Configurations         

SUSE Linux Enterprise Server Version 12.0

  • Recommended Patches
    • Fixes NFS locking issues with fcntl calls
      • kernel-default-3.12.44-52.10.1.x86_64.rpm
    • Open SSL Security Patches - Critical Security Patch for "DOS" and "POODLE" attacks
      • openssl-1.0.1i-5.1.x86_64.rpm
      • libopenssl1_0_0-1.0.1i-5.1.x86_64.rpm
      • libopenssl1_0_0-hmac-1.0.1i-5.1.x86_64.rpm

SUSE Linux Enterprise Server Version 12 SP1

  • Recommended Patches
    • None

SUSE Linux Enterprise Server Version 12 SP2

  • Recommended Patches
    o   None

  SUSE Linux Enterprise Server Version 12 SP3

  • Recommended Patches
    • None

x86_64 64-bit Microsoft Windows  

Windows Manager

  • Native Windows Interface

Compiler

  • Microsoft Visual Studio 2017 v15.7

Tested configurations

Windows 7

  • Recommended Patches
    • None

Windows 10

  • Recommended Patches
    • None

Windows Server 2008 R2

  • Recommended Patches
    • None

Windows Server 2016

  • Recommended Patches
    • None