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Chapter 1 Getting Started
This chapter links to CODE V system requirements, describes the CODE V license types, and tells you
how to contact CODE V Support.

System Requirements
Current hardware and system requirements for computers that will run CODE V can be found online:
https://www.synopsys.com/optical-solutions/codev/hw-systems.html
Note: If your site runs CODE V with licenses managed by the OSG Floating License Manager (FLM),
additional requirements exist for the FLM license server. For information, see Installing CODE V with a
Floating License on page 9.

About Fixed and Floating License
You can run CODE V using either a fixed license or a floating license. A fixed license allows you to run
CODE V only on the computer on which it is installed (see Installing CODE V with a Fixed License on
page 3). A floating license, which is installed on a network server, allows you to run CODE V on any
client computer installed on the same network (see Installing CODE V with a Floating License on page
9). The number of users that can use CODE V concurrently is limited to a predetermined number by the
license management software.

Where You Get Your Installation Files
Where you get your files depends on how you purchased CODE V:
•

Customers who work directly with Synopsys OSG will retrieve their software and license keys
from the Synopsys SolvNetPlus website. For details about obtaining CODE V software and license
key files, see Appendix A, “Using SolvNetPlus to Obtain CODE V Software and Licenses” on
page 27.

•

Customers who work with a CODE V software distributor will obtain their software and license
keys from their local distributor. See the Synopsys Optical Solutions Group Global Contacts page
for contact information. Note that any reference in this manual to SolvNetPlus can be ignored.

Contacting CODE V Support
If you need help or have questions about CODE V that are not answered in the documentation or the
online help, you can contact the CODE V Support team (codev_support@synopsys.com) or your local
distributor. See the Synopsys Optical Solutions Group Global Contacts page for contact information.
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Chapter 2 Installing CODE V with a Fixed
License
This chapter describes how to install CODE V with a fixed license, which allows you to run CODE V
only on the computer on which it is installed. Note that all instructions are for the Microsoft Windows
operating system.

What You Need for Fixed License Installation
Fixed licenses are standalone software copies to be used on one computer only. You will need the
following to run CODE V on a fixed-license system:
•

USB Dongle – the dongle comes with a label that shows its Host ID.

•

License Key File – a license key file that corresponds to your CODE V license and to the Host ID
of the USB dongle you are using.

•

CODE V – You need a copy of CODE V installation files.

For details, see Appendix A, “Using SolvNetPlus to Obtain CODE V Software and Licenses” on
page 27.
Note: For customers working with distributors, please contact your local CODE V software
distributor to obtain your software and license. See the Synopsys Optical Solutions Group Global
Contacts page for contact information.

Installing CODE V
These instructions assume that you have already have the USB dongle, a license key file and the
CODE V installation files.
1. Log on to your computer as Administrator.
2. Navigate to the folder that contains the CODEV installation package.
3. Double-click the file CODEVversion.exe.
where version is the version number for the release (for example, CODEV115FCS.exe).
If a User Account Control dialog box is displayed with the message Do you want to allow this app
to make changes to your PC?, click Yes to continue.
The installation files are extracted, and then the InstallShield Wizard is displayed.
4. Click Next to continue, and follow the instructions in the wizard.
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5. When you get to the License Installations Options, be sure that the Fixed License option is
selected (this is the default setting).

6. Click Next to continue, and follow the instructions in the wizard.
7. When the installation is complete, click Finish to close the wizard.

If you already have a license key for this product, skip to “Installing a License Key File for a
Fixed License” on page 7. If you do not yet have a license key, continue with “Obtaining the
Host ID for a License Dongle” on page 5.
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Obtaining the Host ID for a License Dongle
A license key is designed to work for only one USB dongle, so the license key is associated with a
unique value encoded on the dongle called a Host ID. Before you can request a license key you must
know the Host ID for the license dongle. The Host ID is printed on a label on the USB dongle. You
can also obtain the Host ID by running GetHostID, which reads it from the dongle. If you need to
provide your Host ID to Customer Support or Sales, the recommended method is to use GetHostID to
generate a file that you can send. Follow these steps to run the GetHostID utility.
1. Insert the USB dongle in an active USB port. The beacon on the dongle should be illuminated. If
not, try connecting it to a different USB port.
2. Click the Windows Start button and select CODE V > GetHostID.
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In the following figure, the GetHostID utility displays two lines under the Read Dongle Host ID
button, which indicates that two USB dongles are active on this computer. (Older dongles may
display on the same line a short, eight character Host ID to the left of a longer Host ID. In that
case, either the short or long code may be used to request your license key file on the Synopsys
SolvNetPlus website.)
.

Dongle Host IDs

If the box is empty, click the Read Dongle Host ID button. If the box remains empty, check the
dongle to see whether the LED on it is lit. Light indicates that the dongle has been plugged-in
properly. If the LED is not lit, check the connection or try inserting the dongle into a different
USB port.
3. To create a HostIDs text file (.TXT) that you can send to Customer Support or Sales, in the
GetHostID dialog box click Write Host ID File and then click OK. (If you cannot send the Host
IDs file, open the file, copy the contents of the file and paste it into an email message that you
send to Customer Support or Sales.)
4. To copy the Host ID, select the Host ID, right-click and then click Copy. You can then paste the
Host ID into your desired destination.
5. Click Done to close the GetHostID utility.
6. Continue with “Retrieving License Keys” on page 34 for instructions on retrieving your license
key file from the Synopsys SolvNetPlus website. After you have your license key, go to
“Installing a License Key File for a Fixed License” on page 7.
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Installing a License Key File for a Fixed License
A valid license key file must be installed before you can run CODE V. This procedure assumes that
CODE V is installed (see “Installing CODE V” on page 3) and that you have your license key file
(“Retrieving License Keys” on page 34).
Note: If you start CODE V before you install your license key file, the License Manager Error dialog
box will be displayed. Insert the USB dongle in an active USB port and then click Install License in
the error dialog box to display the Fixed License Installer. Skip to step 3 in the following procedure.
Follow these steps to install your license key file.
1. Insert the USB dongle in an active USB port.
2. To install your license key file, click the Windows Start button and select CODE V > Fixed
License Installer.

The Fixed License Installer is displayed.

3. Click the browse button

.

4. Navigate to the license key file, select it, and click Open.
The path to the license key file is shown in the Fixed License Installer.
CODE V Installation Guide • 7
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5. (Optional) The Start Application After Installing License File is selected by default. You can
clear the check box, if desired.
6. Click Install.
The license key file is installed. If the Start Application After Installing License File check box
was selected, CODE V starts automatically.

Modifying License Options
If you need to change the type of license specified for your CODE V installation (fixed or floating) or
change the host name of the license server to use with a floating license, use the following procedure.
1. Search for and open Add or Remove Programs.
2. In Programs and Features, click the CODE V version you want to modify and then click
Uninstall.
3. When Windows asks if you want to uninstall, click Uninstall.
4. In the InstallShield Wizard Welcome page, the Modify Licensing option is preselected.

5. Click Next.
6. On the License Installation Options page, select the type of license that you want to use (if you are
switching to a floating license, enter the server hostname or IPv4 address for the floating license
server) and click Next.

7. On the Maintenance Information page, confirm your changes and click Next.
8. Click Finish.
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This chapter describes how to install CODE V so that a set of CODE V floating licenses can be shared by a
group of computers on the same network. The number of users that can use CODE V concurrently is limited
to a predetermined number by the licensing software. A single user can open up to eight concurrent CODE V
sessions per floating license per computer. If a user opens more than eight concurrent CODE V sessions on
the same computer, an additional floating license will be used (if available). Note that all instructions are for
the Microsoft Windows operating system.
The floating license capability requires an OSG Floating License Manager, which is a Sentinel RMS license
manager that has been customized for Synopsys OSG software. If you install other Synopsys OSG software
products, they will share the same license management software, and their license keys will be written to the
same license key file. The applications cannot share licenses; they will share only the license server software.

Note: Installing a floating license requires system-administration level training, and should be performed
by someone who is familiar with your network structure. Also, note that you must be logged in as
administrator on the license server.
The steps for installing CODE V to run with a floating license are:
1.

“Selecting a License Server” on page 10

2.

“Installing the OSG Floating License Manager on the License Server” on page 10

3.

“Obtaining the Host ID for a License Dongle on the License Server” on page 17

4.

“Installing the License Key for a Floating License” on page 18

5.

“Installing CODE V on Client Machines” on page 20

What You Need for Floating License Installation
Floating licenses are run on a license server, and operate as a service to client computers attached to the
network. The license server and client computers must be able to communicate with each other using the
UDP protocol. You will need the following to run CODE V:
License Server
•

USB Dongle – the dongle comes with a label that show its Host ID.

•

License Key File – a license key file that corresponds to your CODE V license and to the Host ID of the
USB dongle you are using.

•

Floating License Manager software provided by Synopsys OSG. This guide provides instructions for
installing the OSG Floating License Manager (a Sentinel RMS license manager that has been
customized for Synopsys OSG software). See also “System Requirements” on page 1.
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CODE V Client
•

CODE V – You need a copy of CODE V installation files. Note that the license key file is needed only
on the license server; no license key file is needed on client computers.

•

Server Host Name – the name of the server that is hosting the floating license manager. You must enter
this information during installation.

Selecting a License Server
Before installing any software, you must identify the computer that will act as the floating license server.
This must be a computer connected to a network that can grant access to one or more client machines.

Note: The OSG Floating License Manager communicates with its clients over port 5093 using the UDP
protocol. If you will be managing licenses for client computers across different subnets, you must configure
your routers or firewalls to allow two-way communication across this port.

Installing the OSG Floating License Manager on the License Server
Follow these steps to install the OSG Floating License Manager on the license server. You obtain the OSG
Floating License Manager software from the same source that provides your CODE V software (e.g.,
SolvNetPlus or your local distributor). See Downloading CODE V Software from SolvNetPlus on page 29.
Note: Whenever a new version of CODE V is released, the software on the client machines must be
updated. Check the latest CODE V Readme file to see if the OSG Floating License Manager (FLM) and/or
the license key file must also be updated.
1.

Log on with administrator privileges to the computer that will act as the license server.

2.

If you have previously installed the ORA or OSG Floating License Manager and the Sentinel RMS
License Manager software, you may need to remove them before installing the latest version.
a.

Open Control Panel and select Programs and Features.
If you have the OSG Floating License Admin Tools 9.3 installed, continue with step 3. If you are
running a previous version, you must uninstall both ORA/OSG Floating License Manager Admin
Tools and the Sentinel RMS License Manager.

b.

Select the program to uninstall and then click Uninstall/Change.

c.

Follow the instructions on screen.

d.

If needed, repeat these steps to uninstall additional software.

3.

Navigate to the folder where you downloaded the OSG Floating License Manager, FloatingLM.exe.

4.

Double-click the file FloatingLM.exe.
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The WinZip Self-Extractor for the OSG Floating License Manager installation is displayed.

5.

Click Setup.
The Welcome screen for the OSG Floating Manager Admin Tools wizard is displayed.

6.

Click Next.
The License Agreement screen for the OSG Floating License Manager Admin Tools is displayed.

7.

Click the I Accept option and click Next to continue.

CODEV Installation Guide • 11

Chapter 3 Installing CODE V with a Floating License

The Ready to Install screen is displayed.

8.

Click Install.
The progress screen is displayed while the software is installed.

9.

Accept the default settings for all options.
The Welcome screen for the Sentinel RMS License Manager is displayed.
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10. Click Next.
The License Agreement screen for the Sentinel RMS License Manager wizard is displayed.

11. Click the I Accept option and then click Next to continue.
The Customer Information dialog box is displayed.

12. Click Next to accept the defaults and continue.
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The Destination Folder screen is displayed.

13. Click Next to accept the default and continue.
The Setup Type screen is displayed.

14. Click Next to accept Complete (recommended) and continue.
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The System Firewall Settings screen is displayed. Do not clear the check box; it must remain selected so
that the Sentinel RMS Floating License Manager can add inbound rules for the executable (lservnt.exe).
If you clear this setting CODE V will not be able to obtain the license needed to run.

15. Click Next.
The Ready to Install screen is displayed.

16. Click Install.
The progress screen is displayed while the software is installed.
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When the installation is finished, the Completed screen for the Sentinel License Manager is displayed.

17. Click Finish.
The Completed screen for the OSG Floating License Manager Admin Tools is displayed.

18. Click Finish.
The installation is complete.
19. Reboot your computer if prompted to do so.
If you already have a CODE V license key file, skip to Installing the License Key for a Floating License
on page 18. If you do not yet have a license key file, continue with Obtaining the Host ID for a License
Dongle on the License Server on page 17.
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Obtaining the Host ID for a License Dongle on the License Server
A license key is designed to work for only one USB dongle, so the license key is associated with a unique
value encoded on the dongle called a Host ID. Before you can request a license key you must know the
Host ID for the license dongle. The Host ID is printed on a label on the USB dongle. You can also obtain the
Host ID by running GetHostID, which reads it from the dongle. If you need to provide your Host ID to
Customer Support or Sales, the recommended method is to use GetHostID to generate a file that you can
send.
1.

Insert the USB dongle in a USB port on the license server. The beacon on the dongle should be
illuminated. If not, try connecting it to a different USB port.

2.

Click the Windows Start button and then select OSG Floating License Manager > GetHostID.
In the following figure, the GetHostID utility displays two lines under the Read Dongle Host ID button,
which indicates that two USB dongles are active on this computer. (Older dongles may display on the
same line a short, eight character Host ID to the left of a longer Host ID. In that case, either the short or
long code may be used to request your license key file on the Synopsys SolvNetPlus website.)

.

Dongle Host IDs

If the box is empty, click the Read Dongle Host ID button.
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3.

To create a HostIDs text file that you can send to Customer Support or Sales, click Write Host ID File
and then click OK. (If you cannot send the Host IDs file, open the file, copy the contents of the file and
paste it into an email message that you send to Customer Support or Sales.)

4.

To copy the Dongle Host ID, select the Host ID, right-click and then click Copy. You can then paste the
Host ID into your desired destination.

5.

Click Done to close the GetHostID utility.

6.

Continue with “Retrieving License Keys” on page 34 for instructions on retrieving your license key file
from the Synopsys SolvNetPlus website. After you have your license key, go to “Installing the License
Key for a Floating License” on page 18.

Installing the License Key for a Floating License
After you install the license server software and retrieve a license key, you need to install the license key on
the license server before client machines can successfully run CODE V. The Floating License Installer is
provided for this purpose.
This procedure assumes that you have already obtained a valid CODE V license.dat file from the
SolvNetPlus SmartKeys web page or from your local distributor. To retrieve the file from SolvNetPlus, see
“Retrieving License Keys” on page 34 for instructions.
Follow these steps to install your license key file.
1.

Make sure that the license dongle is inserted in an active USB port on the license server.

2.

Click the Windows Start button and select OSG Floating License Manager > Floating License
Installer.
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The Floating License Installer is displayed, as shown in the following figure.

3.

Click the Browse button

.

4.

In the Open dialog box, navigate to the license key file, select it, and click Open.
The Open dialog box is closed, and the path to the license key file is shown in the Floating License
Installer.

5.

Click the Install button.
The license key file is installed, and the Success dialog box is displayed.
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6.

To close the Floating License Installer, click the red X in the top right corner.
Continue with “Installing CODE V on Client Machines” on page 20.

Installing CODE V on Client Machines
CODE V must be installed on each client machine where it will be used. During the installation, choose
Floating License as the license type, and enter the name of the license manager in the Server Hostname
field.
These instructions assume that you have already obtained CODE V from SolvNetPlus or your local
distributor.
1.

Log on to the client computer as Administrator.

2.

If you downloaded CODE V, navigate to the folder where the installation package was copied.

3.

Double-click the file CODE Vversion.exe
where version is the version number for the release (for example, CODE V115FCS.exe).
The installation files are extracted, and then the InstallShield Wizard is displayed.

4.

Click Next to continue, and follow the instructions in the wizard.

5.

When you get to the License Installations Options, select the Floating License option.

6.

Next to the Server Hostname or IPv4 Address option, enter the name or the IPv4 address for the
computer on which the license manger was installed and click Next to continue. In the following figure,
the name OpticServer is used as an example; be sure to enter the name of your license server.

7.

When the installation is complete, click Finish to close the wizard.

Changing Floating License Options on Client Machines
If you have already installed CODE V to a client machine and then want to switch from a fixed to floating
license or change license servers, refer to “Modifying License Options” on page 8 to see how to modify
license options on a client machine.
For example, in step 6 of that procedure you can change the floating license server hostname or IPv4 address
to make a correction or to point the client machine to a different floating license server.
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In general, there is nothing that you need to do to administrate floating licenses. As long as the license server
machine is operational, connected to the network, and is running the Sentinel service, licenses are available
to clients.

Monitoring License Use
It is possible for all available licenses to be in use, which would prevent additional clients from running
CODE V. In such cases, a system administrator can use the WlmAdmin utility to determine to whom the
module licenses have been allocated.

Note: To use the WlmAdmin utility, either you must be the person who started the license server, or you
must have administrator privileges.
1.

To start the utility from the Windows Start menu, select OSG Floating License Manager >
Administrator Utility.

2.

Expand the list of modules below the license server hostname.

The details presented in the dialog box indicate which client machine and username have checked out the
licenses.

You can also use the WlmAdmin utility to obtain other licensing activity information, such as license servers
detected and details on active licenses. For more information about how to use the WlmAdmin utility, see the
Sentinel System Administrator’s Guide. After the Sentinel software is installed, this manual is available from
the Windows Start menu in OSG Floating License Manager > System Administrator’s Guide.
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Note: Not all functions described in the Sentinel System Administrator’s Guide are supported by CODE V.

All license manager activity is recorded in the file usage.log, which is located in C:\Windows\SYSWOW64.

Reserving Availability of CODE V Licenses Using Sentinel License Manager
By default, CODE V licenses are available to anyone on your server on a first-come, first-served basis.
Therefore, you can use CODE V immediately without using the Sentinel License Manager. However, if and
when you want the access to these licenses more finely tuned for your work priorities, you can use Sentinel
License Manager to reserve the number of licenses available to a group (using license tokens) and to allow or
deny access to users who are members of a group.
Before using the Sentinel License Manager, consider how you want to organize your groups, as there are
many ways to do so. Remembering the following points will help you to decide how to organize your
groups:
•

Any license not specifically reserved can be used by anyone on your server.

•

After you create a group, you can specify the status of individual members as Included (access allowed)
or Excluded (access denied).

•

A user should be assigned as a member of only one group.

•

You can exclude all members of a group from using licenses by specifying 0 licenses for that group.

•

If the total number of license tokens reserved exceeds the number of concurrent copies of CODE V for
which you have licenses (as defined in your license file) then the license file number will be used.

For example:
•

To organize by department, enter each department in your organization as a separate group, assign the
appropriate number of license tokens to each group, and designate each group member as Included or
Excluded. You can change this designation on a regular basis as your work priorities change.

•

To organize by priority, create one group for preferred users and one group for everyone else. In the
preferred user group, designate all members as Included and assign as many licenses as you can allow.
For the second group, enter everyone else in the company that may need the software and the remaining
licenses (tokens) and designate which people are Included and which are Excluded. You can then
change these Included and Excluded designations on a regular basis as the work load changes.

After you decide on an arrangement, you can use the Sentinel License Manager to implement it by setting up
a reservation file as follows:
1.

On the license manager server, start the license manager Administration utility from the Windows Start
button, select OSG Floating License Manager > Administrator Utility.

2.

From the menu at the top of the WlmAdmin window, choose Edit > Reservation File. to open the
Wlsgrmgr window.

3.

Choose File > New to set up a new reservation file. (To modify an existing reservation file, choose File
> Open and then select the lsreserv file in the directory where License Manager is installed.)

4.

Choose Feature > Add. The Add License Reservation Wizard opens. Click Next to continue. The
Feature Version window opens.
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5.

For Feature Name, enter CODE_V (upper case CODE, underscore, upper case V).

6.

For Feature Version, enter ORA (upper case).

7.

Click Next to open the Group window.

8.

Follow these steps to establish a user group:
a.

Enter a name of your choosing that identifies the user group for whom you want to allow or deny
access. The name cannot exceed 64 characters.

b.

In the Tokens field, enter the number of licenses to reserve for that group.

c.

Click Next to open the Members window.
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9.

Follow these steps to add members to the group. Add both members who will be allowed access, as well
as members who will be denied access.
a.

Click the Add button.

b.

In the Name of Member field, enter the member’s network user name. The name cannot exceed 64
characters. (Note that for CODE V, members can be defined only by user name.)

c.

Select User.

d.

Click Included for members who are allowed access and Excluded for members who are denied
access.

e.

Click OK.

f.

Repeat the process to add each user in the group.
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g.

Click Finish on the Members window, to apply the changes and close the window.

10. In the Wisgrmgr window, to add an additional:
a.

group and its members, select Group > Add and repeat steps 7, 8 and 9.

b.

member to an existing group, double click the group name, click the Members tab and repeat step 9.

11. When you are finished, select File > Save As and navigate to the directory where the license manager is
installed.
By default, license manager is installed in:
C:\Program Files (x86)\Common Files\SafeNetSentinel\Sentinel RMS License Manager\WinNT
12. Keep the default file name, lsreserv, and then click Save. The License Manager references this file to
determine which users have access to each feature.
13. Close the Wisgrmgr window and then close the WimAdmin window.
14. Restart the Sentinel RMS License Manager, as follows.
a.

Search for Control and then select System Security

a.

Select Administrative Tools and then Services.

b.

Locate and right-click the Sentinel RMS License Manager in the list of services and select the
Restart option from the pop-up menu.
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Appendix A Using SolvNetPlus to Obtain
CODE V Software and Licenses

Software and license keys for CODE V are available for download from the Synopsys SolvNetPlus
website. This appendix describes how to use the website to download this software products and the
license keys required to use it.
Note: For customers working with distributors, please contact your local CODE V software
distributor to obtain your software and license. See the Synopsys Optical Solutions Group Global
Contacts page for contact information.
Special terms used in these instructions are explained in Glossary on page 39.
The process is described in the following procedures.
1. Signing Up for a SolvNetPlus Account on page 28
2. Downloading CODE V Software from SolvNetPlus on page 29
or
Ordering Media (CDs/DVDs) on page 32
3. Installing CODE V on page 33
4. Obtaining the Host ID for a License Dongle on page 34
5. Retrieving License Keys on page 34
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Signing Up for a SolvNetPlus Account
Before you can download CODE V software and license keys, you must sign up for a Synopsys
SolvNetPlus account. If you already have a SolvNetPlus account, you can skip to Downloading
CODE V Software from SolvNetPlus on page 29.
1. Go to https://solvnetplus.synopsys.com and click REGISTER - CREATE ACCOUNT.

2. Follow the instructions for self registration.
SolvNetPlus will send a verification code to the email address you specified. You must provide
this code to continue with registration.
During the registration process, you will need to enter your company’s Site ID. If you do not know
your company’s Site ID, please contact solvnetplusfeedback@synopsys.com to request it. Be sure
to include your company name and address in the email request.
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Downloading CODE V Software from SolvNetPlus
Follow these steps to download the CODE V product. If you unable to download software, you can
order a CD or DVD instead. See Ordering Media (CDs/DVDs) on page 32 for instructions.
1. Go to https://solvnetplus.synopsys.com and enter your User Name and Password to sign in.
2. In SolvNetPlus, click Downloads.

All Synopsys products currently licensed at your company will be listed.
3. Select the product that you want to download.

4. Select the version you would like to download.
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The Download Details are displayed.

5. In Download Details under Release Alerts, click the Sign up link to display Release Alerts
options that allow you to subscribe to Release Notification emails from SolvNetPlus. These
emails let you know when a new version of CODE V is available for download.

a. Click the product name for which you would like to receive notifications or click ALL to
receive notifications for all products in the list.
b. Click the Add button.
c. Click the Include patch notifications check box. This allows you to receive notifications of
CODE V service releases.
d. Click the Update button.
You are returned to the Download Details page.
6. On the Downloads Details page, click Download Here to download from your browser or read
and follow the instructions for the other download choices.
7. On the Notice page, read the notice and then click Agree and Sign In to continue.
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8. From the list of available files, click the name of the file and then use your browser to open or save
the file.

The following files are available for CODE V 11.5. If you selected a different version of CODE V
in step 4, the files names displayed will be different but will have similar names.
– checksum_info.txt is a file used for internal purposes.
– CODEV115FCS.exe is the installation file for CODE V.
– FloatingLM.exe is for floating license customers. Only the system administrator who will set
up a floating license server needs to download this file. See Installing CODE V with a Floating
License on page 9 for installation instructions.
– README_CV115FCS.txt states whether the selected release requires a new license key file
and describes the key new features.
Next steps:
•

If you need to obtain a license key, see Retrieving License Keys on page 34.

•

If you already have a license key, see Installing CODE V with a Fixed License on page 3 or
Installing CODE V with a Floating License on page 9.
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Ordering Media (CDs/DVDs)
If you unable to download software and would like to order media (CD or DVD) instead, you can do
this directly on the Synopsys SolvNetPlus website. Follow these steps to order media.
1. Go to https://solvnetplus.synopsys.com and enter your User Name and Password to sign in.
2. Click the Downloads tile.
3. Click the MediaCenter link.

4. On the Media Center page, select the product (e.g., CODE V, LightTools, etc.) and click the Add
button.

5. Complete the Shipping Address information and click Continue.
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6. Review the shipping request, shown in the following figure, and click Place Order.

Installing CODE V
Instructions for installing CODE V software and license keys are provided in the following chapters:
•

Getting Started on page 1 - Explains what you need for installation, lists CODE V system
requirements and tells you how to contact CODE V Support.

•

Installing CODE V with a Fixed License on page 3 - With a fixed license, you install the product,
the license dongle, and the license key on the computer where you want to run CODE V.

•

Installing CODE V with a Floating License on page 9 - With a floating license, you install the
license dongle and license key on a network server and the product on one or more client machines
where you want run CODE V; you also install the OSG Floating License Manager on the network
server to manage the licenses.

After you install the CODE V product, continue with Obtaining the Host ID for a License Dongle on
page 34.
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Obtaining the Host ID for a License Dongle
A license key is designed to work for only one USB dongle, so the license key is associated with a
unique value encoded on the dongle called a Host ID. Before you can request a license key you must
know the Host ID for the license dongle. The Host ID is printed on a label on the USB dongle. You
can also obtain the Host ID by running GetHostID, which reads it from the dongle.
For a fixed license, instructions are provided in Obtaining the Host ID for a License Dongle on page
5.
For a floating license, instructions are provided in Obtaining the Host ID for a License Dongle on the
License Server on page 17.

Retrieving License Keys
A license key is a file containing licensing information for your specific USB dongle. You can obtain
a license key using the SmartKeys web page on the Synopsys SolvNetPlus website. Follow these
steps to obtain your license key.
1. On SolvNetPlus Home page, click the Downloads tile, and then click the SmartKeys tab.

2. On the SmartKeys Home page, click the Key Retrieval link.

The SmartKeys Key Retrieval page is displayed.
You can retrieve a license key for a single USB dongle, or you can retrieve license keys for all
Host IDs at your company.
3. To obtain a license key for a single USB dongle, enter the Host ID of your CODE V USB dongle
in the Host ID (Optional) field. If you do not know the Host ID value for your USB dongle, see
Obtaining the Host ID for a License Dongle on page 34.
To obtain license keys for all products and all Host IDs at your company, leave the Host ID
(Optional) field blank and go on to step 4.
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4. Click Retrieve Key, shown in the following figure.

Your CODE V license key will be delivered as a text file attached to an email from the SmartKeys
system. If you did not enter a Host ID in step 3, you will receive a separate email with a single
license key attached for each Host ID at your company. The email will include the Host ID for
which the license key is valid.
5. Save the license key to a convenient location on your computer. You need to access this file to
activate CODE V.
6. See one of the following procedures for instructions on installing the license key to activate your
CODE V product.
– Installing a License Key File for a Fixed License on page 7
– Installing the License Key for a Floating License on page 18
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Appendix B Troubleshooting the CODE V
Network License Installation

If problems arise with CODE V security, a License Manager Error dialog box displays an error message.
Below are a few common security errors with their causes and resolutions. If you are unable to correct the
problem, please contact CODE V Support (codev_support@synopsys.com).

Problem Adding License Keys to the License Server
Problem:

Sentinel: Error [19]: Failed to add license code…

Cause:

This general error message indicates that the license keys were not applied successfully in the
license manager. This can occur if the file where the keys are being read is corrupted. However,
this error an also occur if license keys that have already been successfully entered are entered a
second time.

Solution:

Verify that the license file contains license keys for the current version of CODE V being
installed, and not for an earlier version (the version number is listed in the comments of the
license file received from Synopsys). Also verify that the license file has not become corrupted.
This might occur if the license file has been edited (that is, lines containing license keys are
changed or become line wrapped incorrectly).

Problems Starting CODE V
Problem:

Error #18b - No valid license code for version x.xx found.

Cause:

There has not been a valid license key entered for this version of CODE V.

Solution:

See “Installing the License Key for a Floating License” on page 18 for instructions on
installing license keys.

Problem:

Error #18b(13) - The Floating License manager is out of date.

Cause:

The CODE V version running on this computer is not supported by the Floating License
Manager running on the license server specified in File > License Manager on the Info tab in
the License Server box. (To support the latest client version, the administrator must update the
Floating License Manager software on the license server to a version compatible with the latest
CODE V software version running on its licensed clients. See “System Requirements” on
page 1 for compatibility information. See “Installing the OSG Floating License Manager on the
License Server” on page 10 for installation instructions.)

Solution:

Contact the license server administrator to find out when the license server will be updated.
After the license server is updated, restart CODE V. If the license server administrator directs
you to a new license server, see “Changing Floating License Options on Client Machines” on
page 20.
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Problem:

Error #0xC800100D - License code for version x.xx has expired.

Cause:

The license key for CODE V has expired, or the PC date is before the start date of the license.

Solution:

Verify that the date on the computer is correct. Install the license key for this version of
CODE V on the license manager machine according to the instructions in “Installing the
License Key for a Floating License” on page 18. If a new license key is needed, contact
CODE V Customer Service.

Problem:

Error #8001008 - License manager is not responding. Verify license manager host is
available and license manager process is running.

Cause:

The Sentinel Floating License Manager program has been disabled.

Solution:

Restart the license manager program. To do this: On the PC where the license server is
installed, open the Control Panel (select Start > Settings > Control Panel), select
Administrative Tools and then Services. Locate and right-click on Sentinel in the dialog box,
and select the Start option on the pop-up menu.

Cause:

The license manager machine is unavailable.

Solution:

Solution: Verify that the license manager machine is available on the network.

Cause:

The ORA_LSHOST environment variable is not set or is incorrectly set.

Solution:

Check to make sure the license server name is correct by choosing the File > License
Manager menu in CODE V. If the license server name is incorrect, modify it. See “Changing
Floating License Options on Client Machines” on page 20 for information.

Problem:

An unexpected licensing error has occurred.

Cause:

An error has occurred with the license manager. The License Manager Error dialog box will
contain more specific information about the problem, which is provided by the Sentinel
Floating License Manager program. If you are still having difficulties identifying the problem,
contact CODE V Customer Service for guidance.
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Client (machine)

The client, or client machine, is a computer that has CODE V installed on it, and is configured to use floating licenses (not fixed licenses).

Floating license server
(machine)

The computer onto which the license server software is installed. This computer will
serve licenses to client machines upon request. The application itself need not be
installed on the license server machine.

Host ID

A hexadecimal value encoded on the USB dongle. The Synopsys SmartKeys site and
delivery email reference the Host ID value when license keys are requested and delivered.

License Key

A file containing the encoded license information needed to run CODE V for a specific
USB dongle.

License server software

The software that regulates and protects application use; CODE V uses Sentinel
RMS™. The license server software is installed on and runs as a service on the license
server machine (or host). This service communicates with client machines over the network, and is responsible for checking out licenses to (and checking in licenses from)
those client machines.

Protected application

A single instance of CODE V, which is running on a client machine using a floating
license.

Site ID

A unique number used to identify a specific company. Every company that uses
CODE V and other Synopsys software has a unique site ID.

SmartKeys

The SolvNetPlus page where you submit license key requests.

SolvNetPlus

The Synopsys customer portal (https://solvnet.synopsys.com). This is where you go to
download CODE V software as well as license keys.
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