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Chapter 1 Getting Started
This chapter lists LightTools system requirements and tells you how to contact LightTools Support.
You can run LightTools using either a fixed license or a floating license. A fixed license allows you to
run LightTools only on the computer on which it is installed (see Installing LightTools with a Fixed
License on page 3). A floating license, which is installed on a network server, allows you to run
LightTools on any computer on the same network (see Installing LightTools with a Floating License
on page 11). The number of users that can use LightTools concurrently is limited by the licensing
software.

System Requirements
To install LightTools to run with either a fixed or floating license, you must have:
•

A personal computer with an Intel or AMD processor supporting SSE2 (such as Intel Core, Intel
Atom, AMD Athlon 64, etc.)
To get maximum performance from multi-threaded simulations, we recommend 4 to 16 CPU
cores. LightTools simulation performance scales well with the number of cores, so a computer
with 12 or 16 cores can secure an almost linear increase in performance.
If Intel Hyper-Threading Technology is available on your computer, enabling it will further
increase multi-threaded simulation performance.

•

Operating system: Windows 7 with Service Pack 1 (SP1) for 64-bit

•

Random Access Memory (RAM): 6 GB minimum, 16 GB (or more for extremely large models or
large simulations) recommended

•

Free disk space on the system drive (i.e., the drive on which the operating system is installed) for
prerequisite software: 10 GB
Large models and complex analyses may require significantly more disk space. If LightTools is
installed on a drive other than the system drive, that drive should also have at least 10 GB free disk
space.

•

Free disk space as listed for LightTools components:

Component

Disk Space

Base LightTools product

1654 MB, plus virtual memory equal to 3 times the RAM

Online documentation

121 MB

Tutorial Files

86 MB

Data Exchange Modules,
excluding CATIA V5

323 MB

CATIA V5 Modules

878 MB

SOLIDWORKS Link
Module

42 MB
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•

License keys provided by Synopsys OSG via SolvNet SmartKeys

•

License dongle

•

For the LightTools SOLIDWORKS Link Module, you need a licensed version of SOLIDWORKS
2013 or later (with the latest service pack recommended) installed on the same computer as
LightTools.

•

Display:
– A high-resolution monitor (1280 x 1024 or better) with 16-bit (65536) colors or more
– An OpenGL compliant graphics card with stable ICD driver support recommended. We
recommend that you always use the latest version of the driver for your graphics card.

•

A DVD drive, if installing from a DVD

•

If you will be running LightTools with a floating license, you must also have:
– TCP/IP network protocol
– Floating license manager software provided by Synopsys OSG. This guide provides
instructions for installing the OSG Floating License Manager (a Sentinel RMS license manager
that has been customized for Synopsys OSG software), provided on SolvNet. See Using
Synopsys SolvNet to Obtain LightTools Software and Licenses on page 35 for details about
obtaining this software.

Contacting LightTools Support
If you need help or have questions about LightTools that are not answered in the documentation or the
online help, feel free to contact the LightTools Support team by telephone, fax, or email. LightTools
Support is available from 8 a.m. to 6 p.m., Pacific Time.
Support Hotline (800) 243-8672 (U.S. and Canada only)
Telephone (626) 795-9101
Fax (626) 795-0184
Email: lighttools_support@synopsys.com
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Chapter 2 Installing LightTools with a Fixed
License
You can run LightTools using either a fixed license or a floating license. This chapter describes how to
install the product to run using a fixed license, which allows you to run LightTools only on the
computer on which it is installed.
These instructions assume that you have already downloaded LightTools from the Synopsys SolvNet
website or that you ordered and received a LightTools DVD. If you have not done so, see Using
Synopsys SolvNet to Obtain LightTools Software and Licenses on page 35.

Installing LightTools
1. Log on to your computer as Administrator.
2. If you downloaded LightTools, navigate to the folder where the setup file is located. If you have a
DVD, insert it into the DVD drive and navigate to that drive.
3. Double-click the setup file (e.g., LightToolsversion.exe)
where version is the version number for the release (e.g., LightTools64850FCS.exe).
The WinZip Self-Extractor for LightToolsversion.exe is displayed.
4. Click the Setup button to begin.

The installation files are extracted, and then the InstallShield Wizard is displayed.

5. Click Next to continue.
6. If you are prompted to install .NET Framework, as shown in the following example, click the
Install button.
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The End User License Agreement screen is displayed.

7. Click the I accept option and click Next to continue.
The Destination Folder screen is displayed.

8. To accept the default location for the program and Shared Data files, click Next.
The License Installation Options screen is displayed.
9. Make sure the Fixed License option is selected (it’s the default setting) and click Next to continue.
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The Setup Type screen is displayed.

Note: The data exchange module for CATIA V4 is automatically installed with LightTools if you
select the Typical setup option, but the larger data exchange module for CATIA V5 is not. To install
the CATIA V5 data exchange module with all other LightTools features, select the Complete option
on the Setup Type screen.

If you select the Custom option, you must click the CATIA V5 option to include it; the default setting
for the CATIA V5 option in the Custom installation is not selected.
10. After you select the type of installation you would like to run, click Next to continue.
11. On the Ready to Install the Program screen, click the Install button to begin installing LightTools.
12. When the installation is complete, click Finish to close the wizard.
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If you already have a license key for this product, skip to Installing a License Key for a Fixed
License on page 7. If you do not yet have a license key, continue with Obtaining the Host ID for a
License Dongle on page 6.

Obtaining the Host ID for a License Dongle
A license key is designed to work for only one USB dongle, so the license key is associated with a
unique value encoded on the dongle called a Host ID. Because of this, you need to know the Host ID
for the license dongle before you can retrieve a license key. The Host ID is printed on a label on the
USB dongle; if you’re unable to read the ID on the label, you can also obtain the Host ID by running
a program that reads it from the dongle. In the LightTools installation, the GetHostID utility is
provided for this purpose. Follow these steps to run the GetHostID utility.
1. Insert the USB dongle in an active USB port.
2. Select the Windows Start menu, expand the LightTools group and select GetHostID, shown in the
following figure.

The GetHostID utility is displayed, as shown in the following figure. Under the Read Dongle Host
ID button, a short Host ID and a long Host ID are displayed side by side. To obtain a license key at
this time, you need only the short Host ID (the first eight characters). In this example, the short
Host ID is 80-1DFD2. (Note that in some display configurations, the two Host IDs are separated
by a single space.)
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3. Copy the short Host ID to use when you retrieve your license key on the Synopsys SolvNet
website. See Retrieving License Keys on page 43 for instructions.
4. Click Done to close the GetHostID utility.
After you retrieve your license key, go to Installing a License Key for a Fixed License on page 7.

Installing a License Key for a Fixed License
To install the license key for LightTools, you must have:
•

LightTools installed

•

A license dongle

•

A valid license key (in previous releases, license keys were called license codes.) This procedure
assumes that you have already obtained license keys from the SolvNet SmartKeys web page. If
you have not done so, see Retrieving License Keys on page 43 for instructions.

Note: If you try to start LightTools before you install your license key, the License Manger Error
dialog box is displayed. Click the Install License button on that dialog box to display the Fixed License
Installer and follow steps 3 through 6.
Follow these steps to install your license key.
1. Insert the license dongle in an active USB port.
2. To install your license key, click Start > Programs > LightTools > Fixed License Installer.
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The Fixed License Installer is displayed.

3. Click the browse button

.

4. In the Open dialog box, navigate to the license file, select it, and click Open.
The Open dialog box is closed, and the path to the license key file is shown in the Fixed License
Installer.

5. Click the Install button.
The license key is installed, and the Success dialog box is displayed.

6. Click OK.
LightTools starts automatically.
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Modifying License Options
If you need to change the type of license (e.g., fixed or floating) for your LightTools installation,
follow these steps.
1. Open the InstallShield Wizard:
– If you have a LightTools DVD, insert it into the DVD drive and choose Modify > Change
Licensing Options.
– If you do not have a DVD, follow these steps:
a. From the Windows Start button, select Start.
b. Right-click Control Panel and select Open on the pop-up menu.

c. Under Programs, click Uninstall a Program.

d. In the Name column, locate and select the LightTools program you want to modify.
e. Click the Change button.

2. When the InstallShield Wizard is displayed, click Next.
On the Program Maintenance screen, the Modify option is selected.
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3. Click Next.
4. On the Installation Options page, click the option for Change Licensing Options and click Next.
5. On the License Installation Options page, select the type of license that will be used. If you select
Floating License, enter the Server Hostname as well.
6. Click Next.
7. On the Ready to Modify the Program page, click Install.
When the licensing option has been updated, the wizard displays the InstallShield Wizard
Completed screen.

8. Click Finish to close the wizard.
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Chapter 3 Installing LightTools with a Floating
License
You can run LightTools using either a fixed license or a floating license. This chapter describes how to
install the product to run using a floating license on a network server, which allows you to run
LightTools on any computer on the same network, and describes how to install LightTools on one or
more client machines. The number of users that can use LightTools concurrently is limited to a
predetermined number by the licensing software.
The floating license capability is supported by the OSG Floating License Manager, which is a Sentinel
RMS license manager that has been customized for Synopsys OSG software. If you install other
Synopsys OSG software products, they will share the same license management software, and their
license keys will be written to the same license key file.The applications cannot share licenses; they
share only the license server software.
Note: Installing a floating license requires system-administration-level training and should be
performed by someone who is familiar with your network structure. To perform this installation, you
must be logged on as administrator.
The steps for installing LightTools to run with a floating license are:
1. Selecting a License Server on page 11
2. Installing the OSG Floating License Manager on the License Server on page 12
3. Installing a License Key for a Floating License on page 22
4. Installing LightTools on Client Machines on page 23
5. Administering Floating Licenses on page 28

Selecting a License Server
Before installing any software, you must identify the computer that will act as the license server. This
must be a computer connected to a network that can grant access to one or more client machines.
Note: By default, the License Server communicates via port 5093. If you will be running LightTools
across different subnets, you will have to configure your routers or firewalls to allow two-way
communication across this port.
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Installing the OSG Floating License Manager on the License Server
Follow these steps to install the OSG Floating License Manager, which is provided on the SolvNet
website. See Downloading LightTools Software from SolvNet on page 37 (step 10) for instructions.
Note: If you have any other version of the Sentinel RMS software (e.g., 8.4.1, 8.6), you must first
uninstall that version, as described below.

Before You Begin: To uninstall an earlier version of the Sentinel RMS software, click the Windows Start
menu, and click Control Panel > Programs > Programs and Features. If you have the ORA Floating
License Manager installed, be sure that you uninstall both the ORA Floating License Manager Admin Tools
and the Sentinel RMS License Manager, shown in the following figure

1. Log on to the license server with administrator privileges.
2. Navigate to folder where you downloaded the OSG Floating License Manager, FloatingLM.exe.
3. Double-click the file FloatingLM.exe.
The WinZip Self-Extractor for the OSG Floating License Manager installation is displayed.

4. Click Setup.
The Welcome screen for the OSG Floating Manager Admin Tools wizard is displayed.
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5. Click Next.
The License Agreement screen for the OSG Floating License Manager Admin Tools is displayed.

6. Click the I Accept option and click Next to continue.
The Ready to Install screen is displayed.
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7. Click Install.
The progress screen is displayed while the software is installed.

8. Accept the default settings for all options.
The Welcome screen for the Sentinel RMS License Manager is displayed.

9. Click Next.
The License Agreement screen for the Sentinel RMS License Manager wizard is displayed.
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10. Click the I Accept option and then click Next to continue.
The Customer Information dialog box is displayed.

11. Click Next to accept the defaults and continue.
The Destination Folder screen is displayed.

12. Click Next to accept the default and continue.
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The Setup Type screen is displayed.

13. Click Next to accept Complete (recommended) and continue.
The System Firewall Settings screen is displayed.

14. Click Next (recommended).
If you choose to change the setting on this screen, see Network Firewall Settings on page 19
before proceeding.
The Ready to Install screen is displayed.
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15. Click Install.
The progress screen is displayed while the software is installed.
When the installation is finished, the Completed screen for the Sentinel License Manager is
displayed.

16. Click Finish.
The Completed screen for the OSG Floating License Manager Admin Tools is displayed.

LightTools Installation Guide • 17

CHAPTER 3 Installing LightTools with a Floating License

17. Click Finish.
The installation is complete.
18. Reboot your computer if prompted to do so.
If you already have a license key for this product, skip to Installing a License Key for a Floating
License on page 22 If you do not yet have a license key, continue with Obtaining the Host ID for
a License Dongle on page 20.
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Network Firewall Settings
By default, installing the Sentinel RMS License Manager adds one or more inbound rules for the
executable (lservnt.exe).

This action is enabled by the check box in the InstallShield Wizard dialog shown in the following
figure. If you choose to bypass this action by deselecting this check box, LightTools may not be able
to obtain the license needed to run.

As the dialog explains, the firewall blocking exceptions can be added at a later time. Additionally, if
you want strict firewall settings, you can allow communications only for port 5093 in the Ports setting
of the Inbound Rules.
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Obtaining the Host ID for a License Dongle
A license key is designed to work for only one USB dongle, so the license key is associated with a
unique value encoded on the dongle called a Host ID. Because of this, you need to know the Host ID
for the license dongle before you can request a license key. The Host ID is printed on a label on the
USB dongle; if you’re unable to read the ID on the label, you can also obtain the Host ID by running
a program that reads it from the dongle. In the OSG Floating License Manager installation, the
GetHostID utility is provided for this purpose. Follow these steps to run GetHostID.
1. Insert the USB dongle in an active USB port on the license server.
2. To display the correct Host ID in the GetHostID utility, you need to modify the shortcut to the
utility as follows:
a. Click the Windows Start menu, select OSG Floating License Manager group, right-click
GetHostID and select Properties, shown in the following figure.

b. In the GetHostID Properties dialog box, click the Shortcut tab. For the Target command, add
the following text at the end of the line:
-shortLC -showShortLCInGUI
so that the complete command looks like this:
"C:\Program Files\Optical Research Associates\LightTools
8.5.0\LightTools\GetHostID.exe" -shortLC -showShortLCInGUI
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Be sure that there is a space between .exe" and -shortLC.
c. Click OK to accept the change and close the GetHostID Properties dialog box.
3. Select the Windows Start menu, expand the OSG Floating License Manager group, and select
GetHostID, shown in the following figure.

The GetHostID utility is displayed, as shown in the following figure. Under the Read Dongle Host
ID button, a short Host ID and a long Host ID are displayed side by side. To obtain a license key at
this time, you need only the short Host ID (the first eight characters). In this example, the short
Host ID is 80-1DFD2. (Note that in some display configurations, the two Host IDs are separated
by a single space.)

4. Copy the short Host ID to retrieve your license key on the Synopsys SolvNet website. See
Retrieving License Keys on page 43 for instructions.
5. Click Done to close the GetHostID utility.
After you retrieve your license key, go to Installing a License Key for a Floating License on page
22.
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Installing a License Key for a Floating License
After you install the license server software and retrieve a license key, you need to install the license
key on the license server before client machines can successfully run LightTools. The Floating
License Installer is provided for this purpose.
This procedure assumes that you have already obtained a valid license key from the SolvNet
SmartKeys web page. If you have not done so, see Retrieving License Keys on page 43 for
instructions.
Follow these steps to install your license key file.
1. Make sure that the license dongle is inserted in an active USB port on the license server.
2. Click the Windows Start button on the taskbar, and select All Programs > OSG Floating
License Manager > Floating License Installer.

The Floating License Installer is displayed, as shown in the following figure.

3. Click the Browse button

.

4. In the Open dialog box, navigate to the license key file, select it, and click Open.
The Open dialog box is closed, and the path to the license key file is shown in the Floating License
Installer.
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5. Click the Install button.
The license key file is installed, and the Success dialog box is displayed.

6. To close the Floating License Installer, click the red X in the top right corner.
Continue with Installing LightTools on Client Machines on page 23.

Installing LightTools on Client Machines
LightTools must be installed on each client machine where it will be used. During the installation, you
select Floating License as the license type and then specify the name of the server, which is the
computer on which the license manager is installed.
These instructions assume that you have already downloaded LightTools from the Synopsys SolvNet
website or that you ordered and received a LightTools DVD. If you have not done so, see Using
Synopsys SolvNet to Obtain LightTools Software and Licenses on page 35.
1. Log on to your computer as Administrator.
2. If you downloaded LightTools, navigate to the folder where the setup file is located. If you have a
DVD, insert it into the DVD drive and navigate to that drive.
3. Double-click the setup file (e.g., LightToolsversion.exe)
where version is the version number for the release (e.g., LightTools64850FCS.exe).
The WinZip Self-Extractor for LightToolsversion.exe is displayed.
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4. Click the Setup button to begin.

The installation files are extracted, and then the InstallShield Wizard is displayed.

5. Click Next to continue.
6. If you are prompted to install .NET Framework, as shown in the following example, click the
Install button.

The End User License Agreement screen is displayed.
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7. Click the I accept option and click Next to continue.
The Destination Folder screen is displayed.

8. To accept the default location for the program and Shared Data files, click Next.
The License Installation Options screen is displayed.
9. Select the Floating License option.
10. Next to the Server Hostname, enter the name of the computer on which the license manager was
installed and click Next to continue. In the following figure, the name OpticServer is used as an
example; be sure to enter the name of your license server in this field.

If you want to enter more than one server name, you can do so, as long as you separate the names
with a colon, as shown in the following example. The names ServerHostname1 and
ServerHostname2 are examples; be sure to enter the names of your license servers in this field.
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11. Click Next.
The Setup Type screen is displayed.

Note: The data exchange module for CATIA V4 is automatically installed with LightTools if you
select the Typical setup option, but the larger data exchange module for CATIA V5 is not. To install
the CATIA V5 data exchange module with all other LightTools features, select the Complete option
on the Setup Type screen.

If you select the Custom option, you must click the CATIA V5 option to include it; the default setting
for the CATIA V5 option in the Custom installation is not selected.
12. After you select the type of installation you would like to run, click Next to continue.
13. On the Ready to Install the Program screen, click the Install button to begin installing LightTools.
14. When the installation is complete, click Finish to close the wizard.
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Modifying License Options
If you need to change the type of license (e.g., fixed or floating) for your LightTools installation,
follow these steps.
1. Open the InstallShield Wizard:
– If you have a LightTools DVD, insert it into the DVD drive and choose Modify > Change
Licensing Options.
– If you do not have a DVD, follow these steps:
a. From the Windows Start button, select Start.
b. Right-click Control Panel and select Open on the pop-up menu.

c. Under Programs, click Uninstall a Program.
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d. In the Name column, locate and select the LightTools program you want to modify.
e. Click the Change button.

2. When the InstallShield Wizard is displayed, click Next.
On the Program Maintenance screen, the Modify option is selected.
3. Click Next.
4. On the Installation Options page, click the option for Change Licensing Options and click Next.
5. On the License Installation Options page, select the type of license that will be used. If you select
Floating License, enter the Server Hostname as well.
6. Click Next.
7. On the Ready to Modify the Program page, click Install.
When the licensing option has been updated, the wizard displays the InstallShield Wizard
Completed screen.

8. Click Finish to close the wizard.

Administering Floating Licenses
In general, there is nothing that you need to do to administer the floating licenses. As long as the
floating license server machine is operational, connected to the network, and is running the Sentinel
service, licenses are available to clients.
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Monitoring License Use
It is possible for all available licenses to be in use, which would prevent additional clients from
running LightTools. In such cases, a system administrator can use the WlmAdmin utility to determine
to whom the module licenses have been allocated.
Note: To use the WlmAdmin utility, you must be the person who started the license server, or you
must have administrator privileges.

1. To start the utility, click the Windows Start menu and select Programs > OSG Floating License
Manager > Administrator Utility.
2. Expand the list of modules below the license server hostname.
The details presented in the dialog box indicate which client machine and username have checked
out the licenses. The example below shows that from the license server machine calico, a
LightTools Illumination Module (LTLUM) license is checked out to a user named JDoe, who is
using the client machine sardine.

You can also use the WlmAdmin utility to obtain other licensing activity information, such as license
servers detected, details on active licenses, etc. For more information about how to use the
WlmAdmin utility, see the Sentinel System Administrator’s Guide. After the Sentinel software is
installed, this manual is available by selecting the Windows Start menu and selecting Programs >
OSG Floating License Manager > System Administrator’s Guide.
Note: Not all functions described in the Sentinel System Administrator’s Guide are supported by
LightTools.
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Improving Access to LightTools Licenses with the Sentinel License Manager
By default, LightTools licenses are available to anyone on your server on a first-come, first-served
basis. Therefore, you can use LightTools immediately without using the Sentinel License Manager.
However, if you want to control access to these licenses based on work priorities, you can use the
Sentinel License Manager to reserve copies for or deny access to specific users.
Before using the Sentinel License Manager, consider how you want to organize your groups, keeping
in mind the following points:
•

Anyone on your server can use a license that has not been explicitly reserved.

•

After you create a group, you can specify the status of individual members as Included (access
allowed) or Excluded (access denied).

•

You can exclude all members of a group from using licenses (called license tokens) by specifying
0 licenses for that group.

For example:
•

Organize by department:
If you have departments in your organization, enter each department as a separate group, assign
the appropriate number of license tokens to each group, and designate each group member as
Included or Excluded. You can change this designation for members as needed, according to work
priorities.

•

Organize by priority:
Create a group for preferred users and another group for everyone else. In the preferred user
group, designate all members as Included and assign to them as many licenses as you can allow.
For the second group, you enter everyone else in the company, assign the remaining license
tokens, and designate which people are Included and which are Excluded. You can change the
Included and Excluded designations as the work load changes.

When you are ready to implement this arrangement, you can use the Sentinel License Manager to
create a reservation file, as described in the following steps.
1. On the license manager server, start the license manager administration utility from the Windows
Start button:
Start > All Programs > OSG Floating License Manager > Administrator Utility
The WlmAdmin window is displayed.
2. From the menu at the top of the WlmAdmin window, select Edit > Reservation File.
The Wlsgrmgr window is displayed.
3. To set up a new members group, select File > New.
4. Follow these steps to select a feature.
a. Select Feature > Add.
The Add License Reservation Wizard is displayed.
b. Click Next to continue.
The Feature Version Capacity window is displayed.
c. Enter the appropriate Feature Name.
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You must enter feature names as they appear in the WlmAdmin dialog box, shown in the
following example.

d. For the Feature Version, enter ORA (upper case).

e. Click Next.
The Group window is displayed.
5. To establish a user group, follow these steps.
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a. Enter a name that identifies the user group for which you want to allow or deny access.

b. In the Tokens field, enter the number of licenses to reserve for that group.
c. Click Next.
The Members window is displayed.
6. To add members to the group, follow these steps.
Note: Add members who will be allowed access, as well as members who will be denied access.

a. Click the Add button.

b. In the Name of the Member field, enter the member’s user name. Members can be defined only
by user name and not by the client computer name or IP address.
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c. Select User.
d. Click Included for members who are allowed access or Excluded for members who are denied
access.
e. Click OK on the Member window and repeat the process to add each user in the group.
f. Click Finish on the Members window to apply the changes and close the window.
7. Repeat the process of selecting a feature, establishing a group, and adding members for each group
(steps 4, 5, and 6, above).
8. Select File > Save As and find the directory where the license manager is installed.
By default, the license manager is installed in C:\Program Files\Common Files\SafeNet
Sentinel\Sentinel RMS License Manager\WinNT. A file called lsreserv is created and saved at
this location. The License Manager references this file to determine which users have access to
each feature.
9. Restart the Sentinel RMS License Manager, as described in the following steps.
a. From the Windows Start button, select Start.
b. Right-click Control Panel and select Open on the pop-up menu.
c. Click System and Security.
d. Select Administrative Tools and then Services.
e. Locate and right-click the Sentinel RMS License Manager service in the Services dialog box,
and select the Restart option on the pop-up menu.
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Appendix A Using Synopsys SolvNet to Obtain
LightTools Software and Licenses

Software and license keys for LightTools are available for download from the Synopsys SolvNet
website. This appendix describes how to use the website to download this software products and the
license keys required to use it.
Note: For customers working with distributors, please contact your local LightTools software
distributor to obtain your software and license. See the Synopsys Optical Solutions Group Global
Contacts page for contact information.
Special terms used in these instructions are explained in the Glossary on page 63.
The process is described in the following procedures.
1. Signing Up for a SolvNet Account on page 36
2. Downloading LightTools Software from SolvNet on page 37
or
Ordering Media (CDs/DVDs) on page 39
3. Installing LightTools on page 41
4. Retrieving License Keys on page 43

LightTools Installation Guide • 35

Appendix A Using Synopsys SolvNet to Obtain LightTools Software and Licenses

Signing Up for a SolvNet Account
Before you can download LightTools software and license keys, you must sign up for a Synopsys
SolvNet account. If you already have a SolvNet account, you can skip to Downloading LightTools
Software from SolvNet on page 37.
1. Go to https://solvnet.synopsys.com and click the Sign Up Now link.

2. Follow the instructions for New User Registration.
During the registration process, you will need to enter your company’s Site ID. If you do not know
your company’s Site ID, please contact solvnetfeedback@synopsys.comto request it. Be sure to
include your company name and address in the email request.
SolvNet will send you a confirmation email. Follow the link in the email to complete the
registration process.
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Downloading LightTools Software from SolvNet
Follow these steps to download the LightTools product. If you unable to download software, you can
order a CD or DVD instead. See Ordering Media (CDs/DVDs) on page 39 for instructions.
1. Go to https://solvnet.synopsys.com and enter your User Name and Password to sign in.
2. Click Downloads.
3. All Synopsys products currently licensed at your company will be listed.

4. Select the product you want to download.

5. Select the version you would like to download.

The Downloads page is displayed.
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6. Click the Release Alerts link to display a Release Alerts options that allow you to subscribe to
Release Notification emails from SolvNet. These emails let you know when a new version of
LightTools is available for download.

a. Click the product name for which you would like to receive notifications or click ALL to
receive notifications for all products in the list.
b. Click the Add button.
c. Click the Include patch notifications check box. This allows you to receive notifications of
LightTools service releases.
d. Click the Update button.
You are returned to the Downloads page.
7. On the Downloads page, click Download Here.
8. On the Electronic Software Transfer (EST) page, click YES, I AGREE TO THE ABOVE TERMS
to continue.
9. Click the
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10. Floating license customers: if you are a system administrator setting up a floating license server,
you can also click the
button for the FloatingLM.exe to download the OSG Floating
License Manager at this time. See Installing LightTools with a Floating License on page 11 for
installation instructions.
Note: The FloatingLM.exe installs the new OSG Floating License Manager, which is provided as an
optional upgrade and is compatible with LightTools and CODE V, as well as the LucidShape family
of products. You can also continue to use the Sentinel RMS License Manager v. 8.6.1, which was
available in previous releases and is compatible with LightTools and CODE V.

Ordering Media (CDs/DVDs)
If you unable to download software and would like to order media (CD or DVD) instead, you can do
this directly on the Synopsys SolvNet website. Follow these steps to order media.
1. Go to https://solvnet.synopsys.com and enter your User Name and Password to sign in.
2. Click Downloads.
3. Click the MediaCenter link in the lower right corner.
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4. On the Media Center page, select the product (e.g., CODE V, LightTools, etc.) and click the Add
button.

5. Complete the Shipping Address information and click Continue.
6. Review the shipping request, shown in the following figure, and click Place Order, shown in the
following figure.
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Installing LightTools
Instructions for installing LightTools software and license keys are provided in the following
chapters:
•

Getting Started on page 1 - lists LightTools system requirements and tells you how to contact
LightTools Support.

•

Installing LightTools with a Fixed License on page 3 - With a fixed license, you install the
product, the license dongle, and the license key on the computer where you want to run
LightTools.

•

Installing LightTools with a Floating License on page 11 - With a floating license, you install the
license dongle and license key on a network server and the product on one or more client machines
where you want run LightTools; you also install the OSG Floating License Manager on the
network server to manage the licenses.

After you install the LightTools product, continue with Retrieving License Keys on page 43.

Obtaining the Host ID for a License Dongle
A license key is designed to work for only one USB dongle, so the license key is associated with a
unique value encoded on the dongle called a Host ID. Because of this, you need to know the Host ID
for the license dongle before you can retrieve a license key. The Host ID is printed on a label on the
USB dongle; if you’re unable to read the ID on the label, you can also obtain the Host ID by running a
program that reads it from the dongle. In the LightTools installation, the GetHostID utility is provided
for this purpose. Follow these steps to run GetHostID.
1. Insert the USB dongle in the USB port.
2. Select the Windows Start menu, expand the LightTools group, and select GetHostID, shown in the
following figure.

The GetHostID utility is displayed, as shown in the following figure. Under the Read Dongle Host
ID button, a short Host ID and a long Host ID are displayed side by side. To obtain a license key at
this time, you need only the short Host ID (the first eight characters). In this example, the short
Host ID is 80-1DFD2. (Note that in some display configurations, the two Host IDs are separated
by a single space.)
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3. Copy the short Host ID and go on to Retrieving License Keys on page 43.
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Retrieving License Keys
A license key is a file containing licensing information for your specific USB dongle. You can obtain
license keys using the SmartKeys web page on the Synopsys SolvNet website. Follow these steps to
obtain your license keys.
1. Navigate to the SmartKeys page on SolvNet.
You can go to SmartKeys directly using this link: https://solvnet.synopsys.com/SmartKeys, or you
can navigate there from the SolvNet Downloads page by clicking the SmartKeys link in the lower
right corner.

2. On the SolvNet SmartKeys home page, click the Key Retrieval link.
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The SmartKeys Key Retrieval page is displayed.
You can retrieve a license key for a single USB dongle, or you can retrieve license keys for all
Host IDs at your company.
3. To obtain a license key for a single USB dongle, enter the Host ID of your LightTools USB dongle
in the Host ID (Optional) field. If you do not know the Host ID value for your USB dongle, see
Obtaining the Host ID for a License Dongle on page 41.
To obtain license keys for all products and all Host IDs at your company, leave the Host ID
(Optional) field blank.
4. Click Retrieve Key, shown in the following figure.

Your LightTools license key will be delivered as a text file attached to an email from the
SmartKeys system. If you did not enter a Host ID in step 3, you will receive a separate email with
a single license key attached for each Host ID at your company. The email will include the Host
ID for which the license key is valid.
5. Save the license key to a convenient location on your computer. You need to access this file to
activate LightTools.
6. See one of the following procedures for instructions on installing the license key to activate your
LightTools product.
– Installing a License Key for a Fixed License on page 7
– Installing a License Key for a Floating License on page 22
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If a security problem occurs when you use a LightTools floating license, a License Manager Error
dialog box displays an error message. Below are a few common security errors with their causes and
resolutions. If you are unable to correct the problem, please contact LightTools Support at this link:
lighttools_support@synopsys.com

Problem Adding License Keys to the License Server
Problem:

Sentinel: Error [19]: Failed to add license code …

Cause:

This general error message indicates that the license keys were not applied successfully in
the license manager. This can occur if the file where the codes were being read is
corrupted. However, this error an also occur if license keys that have already been
successfully entered are entered a second time.

Solution: Verify that the license file contains license keys for the current version of LightTools
being installed, and not for an earlier version (the version number is listed in the
comments of the license file received from Synopsys). Also verify that the license file has
not become corrupted. This might occur if the license file has been edited (i.e., lines
containing license keys are changed or become line wrapped incorrectly).

Problems Starting LightTools
Problem:

Error #18b - No valid license code for version x.x.x found.

Cause:

There has not been a valid license key entered for this version of LightTools.

Solution: See Installing a License Key for a Fixed License on page 7 for instructions on installing
license keys.
Problem:

Error #0xC800100D - License code for version x.x.x has expired.

Cause:

The license key for LightTools has expired, or the PC date is before the start date of the
license.

Solution: Verify that the date on the computer is correct. Install the license key for this version of
LightTools on the license manager machine according to the instructions in Installing a
License Key for a Floating License on page 22. If a new license key is needed, contact
LightTools Support.
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Problem:

Error #8001008 - License manager is not responding. Verify license manager host is
available and license manager process is running.

Cause:

The Sentinel Floating License Manager program has been disabled.

Solution: Restart the license manager program. To do this, open the Control Panel (select Start >
Settings > Control Panel), select Administrative Tools and then Services. Locate and
right-click on Sentinel in the dialog box, and select the Start option on the pop-up menu.
Cause:

The license manager machine is unavailable.

Solution: Verify that the license manager machine is available on the network.
Cause:

The ORA_LSHOST environment variable is not set or is incorrectly set.

Solution: Change the Hostname with the Program > Change option, as follows: Windows Start
button > Control Panel > Programs > Uninstall a Program. Select LightTools and
click Change on the menu bar. Select Next > Modify > Change Licensing Options >
Next > Floating License. Enter a name for the Server Hostname. Click Next > Install >
Finish.
Problem:

An unexpected licensing error has occurred.

Cause:

An error has occurred with the license manager. The License Manager Error dialog box
will contain more specific information about the problem, which is provided by the
Sentinel Floating License Manager program. If you are still having difficulties identifying
the problem, contact LightTools Support for guidance.
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Glossary
Host ID

A hexadecimal value encoded on the USB dongle. The Synopsys SmartKeys
site and delivery email reference the Host ID value when license keys are
requested and delivered.

License Key

A file containing the encoded license information needed to run LightTools
for a specific USB dongle.

Site ID

A unique number used to identify a specific company. Every company that
uses LightTools and other Synopsys software has a unique site ID.

SmartKeys

The SolvNet page where you submit license key requests.

SolvNet

The Synopsys customer portal (https://solvnet.synopsys.com). This is where
you go to download LightTools software as well as license keys.
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