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Chapter 1 Getting Started

You can run CODE V using either a fixed license or a floating license. A fixed license allows you to run 
CODE V only on the computer on which it is installed. A floating license, which is installed on a 
network server, allows you to run CODE V on any client computer installed on the same network. The 
number of users that can use CODE V concurrently is limited to a predetermined number by the license 
management software. For details about obtaining CODE V software and license key files, see 
Appendix A, “Using Synopsys SolvNet to Obtain CODE V Software and Licenses”.

Fixed License Installation

Fixed licenses are standalone software copies to be used on one computer only. You will need the 
following to run CODE V on a fixed-license system:

• USB Dongle – the dongle comes with a label that shows its Host ID. 

• License Key File – a license key file that corresponds to your CODE V license and to the Host ID 
of the USB dongle you are using.

• CODE V – You need to obtain a copy of CODE V from SolvNet.

Floating License Installation

Floating licenses are run on a license server, and operate as a service to client computers attached to the 
network. The license server and client computers must be able to communicate with each other using 
the TCP/IP protocol. You will need the following to run CODE V:

License Server

• USB Dongle – the dongle comes with a label that show its Host ID.

• License Key File – a license key file that corresponds to your CODE V license and to the Host ID 
of the USB dongle you are using.

• Floating License Manager software provided by Synopsys OSG. This guide provides instructions 
for installing the OSG Floating License Manager (a Sentinel RMS license manager that has been 
customized for Synopsys OSG software), which is available on the Synopsys SolvNet website. See 
Appendix A, “Using Synopsys SolvNet to Obtain CODE V Software and Licenses” for details 
about obtaining this software.

CODE V Client

• CODE V – You need to obtain a copy of CODE V from SolvNet. Note that a license key file is not 
needed when installing CODE V on a client computer.

System Requirements

Current system requirements can be found online:

http://optics.synopsys.com/codev/codev-hw-systems.html

http://optics.synopsys.com/codev/codev-hw-systems.html
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Contacting CODE V Technical Support

If you need help or have questions about CODE V that are not answered in the documentation or 
the online help, feel free to contact the CODE V Technical Support team by telephone, fax, or 
email. Technical support is available from 8 a.m. to 5 p.m., Pacific Time.

Technical Support Hotline (800) 243-8672 (U.S. and Canada only)

Telephone (626) 795-9101

Fax (626) 795-0184

Email: codev_support@synopsys.com

mailto:ora_support@synopsys.com
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Chapter 2 Installing CODE V with a Fixed 
License

This chapter describes how to install CODE V with a fixed license, which allows you to run CODE V 
only on the computer on which it is installed. Note that all instructions are for the Microsoft Windows 
operating system.

These instructions assume that you have already downloaded from SolvNet the CODE V software and 
a license key file. If you have not done so, see “Using Synopsys SolvNet to Obtain CODE V Software 
and Licenses” on page 27.

Installing CODE V

1. Log on to your computer as Administrator.

2. Navigate to the folder to which the CODEV installation package was copied. 

3. Double-click the file CODEVversion.exe.

where version is the version number for the release (for example, CODEV110FCS.exe).

The WinZip Self-Extractor for CODEVversion.exe is displayed.

4. Click Setup to begin.

The installation files are extracted, and then the InstallShield Wizard is displayed.

5. Click Next to continue, and follow the instructions in the wizard.

When you get to the License Installations Options, be sure that the Fixed License option is 
selected (this is the default setting) and click Next to continue. 

6. When the installation is complete, click Finish to close the wizard.
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Obtaining the Host ID for a License Dongle

A license key is designed to work for only one USB dongle, so the license key is associated with a 
unique value encoded on the dongle called a Host ID. Because of this, you need to know the Host ID 
for the license dongle before you can retrieve a license key file. The Host ID is printed on a label on 
the USB dongle; if you’re unable to read the ID on the label, you can also obtain the Host ID by 
running a program that reads it from the dongle. In the CODEV installation, the GetHostID utility is 
provided for this purpose. Follow these steps to run the GetHostID utility.

1. Insert the USB dongle in an active USB port.

2. Select the Windows Start menu, expand the CODEV group and select GetHostID, shown in the 
following figure.

The GetHostID utility is displayed, as shown in the following figure. In this examples, the Host 
ID for the USB dongle is 80-27345. 
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.

3. Copy the Host ID to use when you retrieve your license key on the Synopsys SolvNet website. See 
“Retrieving License Keys” on page 35 for instructions.

4. Click Done to close the GetHostID utility.

After you retrieve your license key, go to “Installing a License Key File for a Fixed License” on 
page 5.

Installing a License Key File for a Fixed License

A valid license key file must be installed before you can run CODE V. This procedure assumes that 
CODE V is installed and that you have your license key file.

Follow these steps to install your license key file.

1. Insert the USB dongle in an active USB port.

2. To install your license key file, click Start > Programs > CODE V > Fixed License Installer. 

The Fixed License Installer is displayed.

3. Click the browse button .

4. Navigate to the license key file, select it, and click Open. 

The path to the license key file is shown in the Fixed License Installer.

5. Click Install.

The license key file is installed, and CODE V starts automatically. 

Note:  If you start CODE V before you install your license key file, the License Manger Error 
dialog box will be displayed. Click Install License in that dialog box to display the Fixed License 
Installer and then skip to step 2 in the following procedure.
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Modifying License Options

If you need to change the type of license specified for your CODE V installation (fixed or floating), 
use the following procedure.

1. Select Start > Control Panel, and click Programs and Features.

2. Click the CODE V program you want to modify.

3. Click Uninstall/Change. 

4. In the InstallShield Wizard Welcome page, the Modify Licensing option is preselected. 

5. Click Next. 

6. On the License Installation Options page, select the type of license that you want to use (if you are 
switching to a floating license, enter the server hostname or IPv4 address for the floating license 
server) and click Next.

7. On the Maintenance Information page, confirm your changes and click Next.

8. Click Finish.
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Chapter 3 Installing CODE V with a Floating 
License

This chapter describes how to install a floating license on a network server, which allows you to run 
CODE V on any client computer installed on the same network. The number of users that can use CODE V 
concurrently is limited to a predetermined number by the licensing software. Note that all instructions are for 
the Microsoft Windows operating system.

The floating license capability is supported by the OSG Floating License Manager, which is a Sentinel RMS 
license manager that has been customized for Synopsys OSG software. If you install other Synopsys OSG 
software products, they will share the same license management software, and their license keys will be 
written to the same license key file. The applications cannot share licenses; they will share only the license 
server software.

The steps for installing CODE V to run with a floating license are:

1. “Selecting a License Server” on page 7

2. “Installing the OSG Floating License Manager on the License Server” on page 8

3. “Network Firewall Settings” on page 14

4. “Installing the License Key for a Floating License” on page 17

5. “Installing CODE V on Client Machines” on page 19

Selecting a License Server

Before installing any software, you must identify the computer that will act as the floating license server. 
This must be a computer connected to a network that can grant access to one or more client machines.

Note: Installing a floating license requires system-administration level training, and should be performed 
by someone who is familiar with your network structure. Also, note that you must be logged in as 
administrator on the license server.

Note: By default, the License Server communicates via port 5093. If you will be running CODE V across 
different subnets, you will have to configure your routers or firewalls to allow two-way communication 
across this port. See Appendix B: "Troubleshooting the CODE V Network License Installation".
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Installing the OSG Floating License Manager on the License Server

These instructions apply to the OSG Floating License Manager software that you download from SolvNet. 
Follow these steps to install the OSG Floating License Manager on the license server.

Before You Begin: To uninstall an earlier version of the Sentinel RMS software, click the Windows Start 
menu, and click Control Panel > Programs > Programs and Features. If you have the ORA Floating 
License Manager installed, be sure that you uninstall both the ORA Floating License Manager Admin Tools 
and the Sentinel RMS License Manager, shown in the following figure.

1. Log on to the license server with administrator privileges.

2. Navigate to the folder where you downloaded the OSG Floating License Manager, FloatingLM.exe.

3. Double-click the file FloatingLM.exe.

The WinZip Self-Extractor for the OSG Floating License Manager installation is displayed.

4. Click Setup.

The Welcome screen for the OSG Floating Manager Admin Tools wizard is displayed.

Note: If you have any other version of the Sentinel RMS license manager software (e.g., 8.4.1, 
8.6), you must first uninstall that version as described below.
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5. Click Next.

The License Agreement screen for the OSG Floating License Manager Admin Tools is displayed.

6. Click the I Accept option and click Next to continue.

The Ready to Install screen is displayed.
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7. Click Install.

The progress screen is displayed while the software is installed.

8. Accept the default settings for all options.

The Welcome screen for the Sentinel RMS License Manager is displayed.

9. Click Next.

The License Agreement screen for the Sentinel RMS License Manager wizard is displayed.



CODEV Installation Guide • 11

Chapter 3 Installing CODE V with a Floating License

10. Click the I Accept option and then click Next to continue.

The Customer Information dialog box is displayed.

11. Click Next to accept the defaults and continue.

The Destination Folder screen is displayed.

12. Click Next to accept the default and continue.
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The Setup Type screen is displayed. 

13. Click Next to accept Complete (recommended) and continue.

The System Firewall Settings screen is displayed.

14. Click Next (recommended).

If you choose to change the setting on this screen, see “Network Firewall Settings” on page 14 before 
proceeding.

The Ready to Install screen is displayed.
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15. Click Install.

The progress screen is displayed while the software is installed.

When the installation is finished, the Completed screen for the Sentinel License Manager is displayed.

16. Click Finish.

The Completed screen for the OSG Floating License Manager Admin Tools is displayed.
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17. Click Finish.

The installation is complete. 

18. Reboot your computer if prompted to do so.

If you already have a CODE V license key, skip to Installing the License Key for a Floating License on 
page  17. If you do not yet have a license key, continue with Obtaining the Host ID for a License Dongle 
on page  15.

Network Firewall Settings

By default, installing the Sentinel RMS Floating License Manager adds one or more inbound rules for the 
executable (lservnt.exe). 

This action is enabled by the check box in the InstallShield Wizard dialog shown in the following figure. If 
you choose to bypass this action by deselecting this check box, CODE V may not be able to obtain the 
license needed to run.

As the dialog explains, the firewall blocking exceptions can be added at a later time. Additionally, if you 
want strict firewall settings, you can allow communications only for port 5093 in the Ports setting of the 
Inbound Rules.
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Obtaining the Host ID for a License Dongle

A license key is designed to work for only one USB dongle, so the license key is associated with a unique 
value encoded on the dongle called a Host ID. Because of this, you need to know the Host ID for the license 
dongle before you can request a license key. The Host ID is printed on a label on the USB dongle; if you’re 
unable to read the ID on the label, you can also obtain the Host ID by running a program that reads it from 
the dongle. In the OSG Floating License Manager installation, the GetHostID utility is provided for this 
purpose. Follow these steps to run GetHostID.

1. Insert the USB dongle in an active USB port on the license server. 

2. To display the correct Host ID in the GetHostID utility, you need to modify the shortcut to the utility as 
follows:

a. Click the Windows Start menu, select OSG Floating License Manager group, right-click GetHostID 
and select Properties, shown in the following figure. 

b. In the GetHostID Properties dialog box, click the Shortcut tab. For the Target command, add the 
following text at the end of the line:

-shortLC -showShortLCInGUI

so that the complete command looks like this:

"C:\Program Files (x86)\Common Files\Optical Research 
Associates\FLM\Admin.net\GetHostID.exe" -shortLC -showShortLCInGUI

Be sure that there is a space between .exe" and -shortLC.

c. Click OK to accept the change and close the GetHostID Properties dialog box.
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3. Select the Windows Start menu, expand the OSG Floating License Manager group, and select 
GetHostID, shown in the following figure.

4. The GetHostID utility is displayed, as shown in the following figure. Under the Read Dongle Host ID 
button, a short Host ID and a long Host ID are displayed side by side. To obtain a license key at this 
time, you need only the short Host ID (the first eight characters). In this example, the Host ID for the 
USB dongle is 80-27345.(Note that in some display configurations, the two Host IDs are displayed 
farther apart.)

.

5. Copy the short Host ID to retrieve your license key file on the Synopsys SolvNet website. See 
“Retrieving License Keys” on page 35 for instructions.

6. Click Done to close the GetHostID utility.

After you retrieve your license key, go to “Installing the License Key for a Floating License” on 
page 17.
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Installing the License Key for a Floating License

After you install the license server software and retrieve a license key, you need to install the license key on 
the license server before client machines can successfully run CODE V. The Floating License Installer is 
provided for this purpose. 

This procedure assumes that you have already obtained a valid CODE V license.dat file from the SolvNet 
SmartKeys web page. If you have not done so, see “Retrieving License Keys” on page 35 for instructions.

Follow these steps to install your license key file.

1. Make sure that the license dongle is inserted in an active USB port on the license server. 

2. Click the Windows Start button on the taskbar, and select All Programs > OSG Floating License 
Manager > Floating License Installer.

The Floating License Installer is displayed, as shown in the following figure.

3. Click the Browse button .

4. In the Open dialog box, navigate to the license key file, select it, and click Open.

The Open dialog box is closed, and the path to the license key file is shown in the Floating License 
Installer.
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5. Click the Install button.

The license key file is installed, and the Success dialog box is displayed.

6. To close the Floating License Installer, click the red X in the top right corner.

Continue with “Installing CODE V on Client Machines” on page 19.
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Installing CODE V on Client Machines

CODE V must be installed on each client machine where it will be used. During the installation, choose 
Floating License as the license type, and enter the name of the license manager in the Server Hostname 
field. 

These instructions assume that you have already downloaded CODE V from SolvNet.

1. Log on to your computer as Administrator.

2. If you downloaded CODE V, navigate to the folder where the installation package was copied. 

3. Double-click the file CODE Vversion.exe

where version is the version number for the release (for example, CODE V110FCS.exe).

The WinZip Self-Extractor for CODE Vversion.exe is displayed.

4. Click Setup to begin.

The installation files are extracted, and then the InstallShield Wizard is displayed.

5. Click Next to continue, and follow the instructions in the wizard.

6. When you get to the License Installations Options, select the Floating License option.

7. Next to the Server Hostname or IPv4 Address option, enter the name or the IPv4 address for the 
computer on which the license manger was installed and click Next to continue. In the following figure, 
the name OpticServer is used as an example; be sure to enter the name of your license server.

8. When the installation is complete, click Finish to close the wizard.

Modifying License Options

If you need to change the type of license specified for your CODE V installation (fixed or floating), use the 
following procedure.

1. Select Start > Control Panel, and click Programs and Features.
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2. Click the CODE V program you want to modify.

3. Click Uninstall/Change. 

4. In the InstallShield Wizard Welcome page, the Modify Licensing option is preselected. 

5. Click Next. 

6. On the License Installation Options page, select the type of license that you want to use (if you are 
switching to a floating license, enter the server hostname or IPv4 address for the floating license server) 
and click Next.

7. On the Maintenance Information page, confirm your changes and click Next.

8. Click Finish.
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In general, there is nothing that you need to do to administrate floating licenses. As long as the license server 
machine is operational, connected to the network, and is running the Sentinel service, licenses are available 
to clients.

Monitoring License Use

It is possible for all available licenses to be in use, which would prevent additional clients from running 
CODE V. In such cases, a system administrator can use the WlmAdmin utility to determine to whom the 
module licenses have been allocated.

1. To start the utility, click the Windows Start menu and select All Programs > OSG Floating License 
Manager > Administrator Utility.

2. Expand the list of modules below the license server hostname.

The details presented in the dialog box indicate which client machine and username have checked out the 
licenses.

Note: To use the WlmAdmin utility, either you must be the person who started the license server, or you 
must have administrator privileges.
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You can also use the WlmAdmin utility to obtain other licensing activity information, such as license servers 
detected and details on active licenses. For more information about how to use the WlmAdmin utility, see 
the Sentinel System Administrator’s Guide. After the Sentinel software is installed, this manual is available 
by selecting the Windows Start menu and selecting All Programs > OSG Floating License Manager > 
System Administrator’s Guide.

All license manager activity is recorded in the file usage.log, which is located in C:\Windows\SYSWOW64.

Improving Access to CODE V Licenses with the Sentinel License Manager

By default, CODE V licenses are available to anyone on your server on a first-come, first-served basis. 
Therefore, you can use CODE V immediately without using the Sentinel License Manager. However, if and 
when you want the access to these licenses more finely tuned for your work priorities, you can reserve copies 
and deny access with the Sentinel License Manager.

Before using the Sentinel License Manager, consider how you want to organize your groups, as there are 
many ways to do so. Remembering the following points will help you to decide how to organize your 
groups:

• Any license not specifically reserved can be used by anyone on your server.

• After you add a user to a group, you can change the status for that user to Included (access allowed) or 
Excluded (access denied).

• If you want to exclude all members of a group from using license tokens for a feature, you can specify 0 
licenses (called tokens).

For example:

• If you have different departments in your organization, you may want to enter each department as a 
separate group, assign a certain number of license tokens to each group, and designate each group 
member as Included or Excluded. You can change this designation on a regular basis as your work 
priorities change.

• Another arrangement would be to create one group for preferred users and one group for everyone else. 
In the preferred user group, you could designate all members as Included and assign as many licenses as 
you can allow. For the second group, you could enter everyone else in the company and the remaining 
licenses (tokens) and designate which people are Included and which are Excluded. You can then 
change these Included and Excluded designations on a regular basis as the work load changes. 

After you decide on an arrangement, you can use the Sentinel License Manager to implement it by setting up 
a reservation file as follows:

1. Start the utility by clicking the Windows Start menu and select All Programs > OSG Floating License 
Manager > Administrator Utility.

2. From the menu at the top of the WlmAdmin window, choose Edit > Reservation File. to open the 
Wlsgrmgr window.

3. Choose File > New. This selection clears the system for setting up a new member group.

Note: Not all functions described in the Sentinel System Administrator’s Guide are supported by CODE V.
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4. 4. Select a feature. CODE V does not have a separate set of features, so CODE V is the only feature 
choice.

a. Choose Feature > Add. The Add License Reservation Wizard opens. Click Next to continue. The 
Feature Version window opens.

b. For Feature Name, enter CODE_V (upper case CODE, underscore, upper case V).

c. For Feature Version, enter ORA (upper case). 

d. Click Next to open the Group window.

5. Establish a user group:

a. Enter a name of your choosing that identifies the user group for whom you want to allow or deny 
access.

b. In the Tokens field, enter the number of licenses of the available licenses to reserve for that group.

c. Click Next to open the Members window.

6. Add each member to the group. Add members who will be allowed access, as well as members who will 
be denied access.
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a. Click the Add button.

b. In the Name of Member dialog box, enter either the user’s login name or machine (host) ID.

c. Select either User or Machine, depending on which you have provided in the previous step.

d. Click Included for members who will be allowed access and Excluded for members who will be 
denied access.

e. Click OK.

f. Repeat the process of adding a member for each user in the group.

g. In the Add Members to Group window, click Finish.
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7. Repeat the process of selecting features, establishing groups, and adding members for each group (steps 
4, 5, and 6, above).

8. Select File > Save As and find the directory where the license manager is installed.

By default, the license manager is installed in:

C:\Program Files (x86)\Common Files\SafeNetSentinel\Sentinel RMS License Manager\WinNT

A file called lsreserv is created and saved at this location. The License Manager references this file to 
determine which users have access to each feature.

9. Restart the Sentinel RMS License Manager, as follows.

a. From the Windows Start button, select Start > Control Panel.

b. Select System and Security > Administrative Tools > Services.

c. Select the Sentinel RMS License Manager in the list of services and select the Restart option, 
shown in the following figure.
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Appendix A Using Synopsys SolvNet to Obtain 
CODE V Software and Licenses

Software and license keys for CODE V are available for download from the Synopsys SolvNet 
website. This appendix describes how to use the website to download this software products and the 
license keys required to use it.

The process is described in the following procedures.

1. Signing Up for a SolvNet Account on page  28

2. Downloading CODE V Software from SolvNet on page  29

or

Ordering Media (CDs/DVDs) on page  31

3. Installing CODE V on page  33

4. Retrieving License Keys on page  35

Note:  For customers working with distributors, please contact your local CODE V software 
distributor to obtain your software and license. See the Synopsys Optical Solutions Group Global 
Contacts page for contact information.

https://optics.synopsys.com/support/support-global-contacts.html
https://optics.synopsys.com/support/support-global-contacts.html
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Signing Up for a SolvNet Account

Before you can download CODE V software and license keys, you must sign up for a Synopsys 
SolvNet account. If you already have a SolvNet account, you can skip to Downloading CODE V 
Software from SolvNet on page  29.

1. Go to https://solvnet.synopsys.com and click the Sign Up Now link.

2. Follow the instructions for New User Registration.

During the registration process, you will need to enter your company’s Site ID. If you do not know 
your company’s Site ID, please contact solvnetfeedback@synopsys.comto request it. Be sure to 
include your company name and address in the email request.

SolvNet will send you a confirmation email. Follow the link in the email to complete the 
registration process.

https://solvnet.synopsys.com
mailto:solvnetfeedback@synopsys.com
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Downloading CODE V Software from SolvNet

Follow these steps to download the CODE V product. If you unable to download software, you can 
order a CD or DVD instead. See Ordering Media (CDs/DVDs) on page  31 for instructions.

1. Go to https://solvnet.synopsys.com and enter your User Name and Password to sign in. 

2. Click Downloads.

3. All Synopsys products currently licensed at your company will be listed.

4. Select the product you want to download. 

5. Select the version you would like to download.

The Downloads page is displayed.

https://solvnet.synopsys.com
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6. Click the Release Alerts link to display a Release Alerts options that allow you to subscribe to 
Release Notification emails from SolvNet. These emails let you know when a new version of 
CODE V is available for download.

a. Click the product name for which you would like to receive notifications or click ALL to 
receive notifications for all products in the list.

b. Click the Add button.

c. Click the Include patch notifications check box. This allows you to receive notifications of 
CODE V service releases.

d. Click the Update button.

You are returned to the Downloads page. 

7. On the Downloads page, click Download Here.7

8. On the Electronic Software Transfer (EST) page, click YES, I AGREE TO THE ABOVE TERMS 
to continue.

9. Click the  button, shown in the following figure, to begin downloading the software.
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10. Floating license customers: if you are a system administrator setting up a floating license server, 
you can also click the  button for the FloatingLM.exe to download the OSG Floating 
License Manager at this time. See Installing CODE V with a Floating License on page 7 for 
installation instructions.

Ordering Media (CDs/DVDs)

If you unable to download software and would like to order media (CD or DVD) instead, you can do 
this directly on the Synopsys SolvNet website. Follow these steps to order media.

1. Go to https://solvnet.synopsys.com and enter your User Name and Password to sign in. 

2. Click Downloads.

3. Click the MediaCenter link in the lower right corner.

Note:  The FloatingLM.exe installs the new OSG Floating License Manager, which is provided as an 
optional upgrade and is compatible with LightTools and CODE V, as well as the LucidShape family 
of products. You can also continue to use the Sentinel RMS License Manager v. 8.6.1, which was 
available in previous releases and is compatible with LightTools and CODE V.

https://solvnet.synopsys.com
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4. On the Media Center page, select the product (e.g., CODE V, LightTools, etc.) and click the Add 
button.

5. Complete the Shipping Address information and click Continue.

6. Review the shipping request, shown in the following figure, and click Place Order.
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Installing CODE V

Instructions for installing CODE V software and license keys are provided in the following chapters:

• Getting Started on page  1 - lists CODE V system requirements and tells you how to contact 
CODE V Support.

• Installing CODE V with a Fixed License on page  3 - With a fixed license, you install the product, 
the license dongle, and the license key on the computer where you want to run CODE V.

• Installing CODE V with a Floating License on page  7 - With a floating license, you install the 
license dongle and license key on a network server and the product on one or more client machines 
where you want run CODE V; you also install the OSG Floating License Manager on the network 
server to manage the licenses.

After you install the CODE V product, continue with Retrieving License Keys on page  35.

Obtaining the Host ID for a License Dongle

A license key is designed to work for only one USB dongle, so the license key is associated with a 
unique value encoded on the dongle called a Host ID. Because of this, you need to know the Host ID 
for the license dongle before you can retrieve a license key. The Host ID is printed on a label on the 
USB dongle; if you’re unable to read the ID on the label, you can also obtain the Host ID by running a 
program that reads it from the dongle. In the CODE V installation, the GetHostID utility is provided 
for this purpose. Follow these steps to run GetHostID.

1. Insert the USB dongle in the USB port. 

2. Select the Windows Start menu, expand the CODE V group, and select GetHostID, shown in the 
following figure. 

The GetHostID utility is displayed, as shown in the following figure. In this example, the Host ID 
for the USB dongle is 80-27345.



34 • CODE V Installation Guide

Appendix A Using Synopsys SolvNet to Obtain CODE V Software and Licenses

3. Copy the Host ID and go on to Retrieving License Keys on page  35.
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Retrieving License Keys

A license key is a file containing licensing information for your specific USB dongle. You can obtain 
license keys using the SmartKeys web page on the Synopsys SolvNet website. Follow these steps to 
obtain your license keys.

1. Navigate to the SmartKeys page on SolvNet. 

You can go to SmartKeys directly using this link: https://solvnet.synopsys.com/SmartKeys, or you 
can navigate there from the SolvNet Downloads page by clicking the SmartKeys link in the lower 
right corner. 

2. On the SolvNet SmartKeys home page, click the Key Retrieval link.

The SmartKeys Key Retrieval page is displayed. 

https://solvnet.synopsys.com/SmartKeys
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You can retrieve a license key for a single USB dongle, or you can retrieve license keys for all 
Host IDs at your company. 

3. To obtain a license key for a single USB dongle, enter the Host ID of your CODE V USB dongle 
in the Host ID (Optional) field. If you do not know the Host ID value for your USB dongle, see 
Obtaining the Host ID for a License Dongle on page  33.

To obtain license keys for all products and all Host IDs at your company, leave the Host ID 
(Optional) field blank and go on to step 4. 

4. Click Retrieve Licenses, shown in the following figure.

Your CODE V license key will be delivered as a text file attached to an email from the SmartKeys 
system. If you did not enter a Host ID in step 3, you will receive a separate email with a single 
license key attached for each Host ID at your company. The email will include the Host ID for 
which the license key is valid. 

5. Save the license key to a convenient location on your computer. You need to access this file to 
activate CODE V. 

6. See one of the following procedures for instructions on installing the license key to activate your 
CODE V product.

– Installing a License Key File for a Fixed License on page  5

– Installing the License Key for a Floating License on page  17
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If problems arise with CODE V security, a License Manager Error dialog box displays an error message. 
Below are a few common security errors with their causes and resolutions. If you are unable to correct the 
problem, please contact CODE V Support (codev_support@synopsys.com).

Problem Adding License Keys to the License Server

Problem: Sentinel: Error [19]: Failed to add license code…

Cause: This general error message indicates that the license keys were not applied successfully in the 
license manager. This can occur if the file where the keys are being read is corrupted. However, 
this error an also occur if license keys that have already been successfully entered are entered a 
second time.

Solution: Verify that the license file contains license keys for the current version of CODE V being 
installed, and not for an earlier version (the version number is listed in the comments of the 
license file received from Synopsys). Also verify that the license file has not become corrupted. 
This might occur if the license file has been edited (that is, lines containing license keys are 
changed or become line wrapped incorrectly).

Problems Starting CODE V

Problem: Error #18b - No valid license code for version x.xx found.

Cause: There has not been a valid license key entered for this version of CODE V. 

Solution: See “Installing the License Key for a Floating License” on page 17 for instructions on 
installing license keys. 

Problem: Error #0xC800100D - License code for version x.xx has expired. 

Cause: The license key for CODE V has expired, or the PC date is before the start date of the license.

Solution: Verify that the date on the computer is correct. Install the license key for this version of 
CODE V on the license manager machine according to the instructions in “Installing the 
License Key for a Floating License” on page 17. If a new license key is needed, contact 
CODE V Customer Service.

Problem: Error #8001008 - License manager is not responding. Verify license manager host is 
available and license manager process is running.

Cause: The Sentinel Floating License Manager program has been disabled.

mailto:ora_support@synopsys.com
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Solution: Restart the license manager program. To do this: On the PC where the license server is 
installed, open the Control Panel (select Start > Settings > Control Panel), select 
Administrative Tools and then Services. Locate and right-click on Sentinel in the dialog box, 
and select the Start option on the pop-up menu.

Cause: The license manager machine is unavailable.

Solution: Solution: Verify that the license manager machine is available on the network.

Cause: The ORA_LSHOST environment variable is not set or is incorrectly set.

Solution: Check to make sure the license server name is correct by choosing the File > License 
Manager menu in CODE V. If the license server name is incorrect, modify it. See “Modifying 
License Options” on page 19 for instructions.

Problem: An unexpected licensing error has occurred.

Cause: An error has occurred with the license manager. The License Manager Error dialog box will 
contain more specific information about the problem, which is provided by the Sentinel 
Floating License Manager program. If you are still having difficulties identifying the problem, 
contact CODE V Customer Service for guidance.
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Document Overview

This document includes licensing information relating to free and open-source software ("FOSS") included 
with Synopsys's® CODE V® products (the "SOFTWARE"). The terms of the applicable FOSS license(s) 
govern Synopsys's® distribution and your use of the SOFTWARE. Synopsys® and the third-party authors, 
licensors, and distributors of the SOFTWARE disclaim all warranties and all liability arising from any and 
all use and distribution of the SOFTWARE. To the extent the FOSS is provided under an agreement with 
Synopsys® that differs from the applicable FOSS license(s), those terms are offered by Synopsys® alone.

Synopsys® has reproduced below copyright and other licensing notices appearing within the FOSS 
packages. While Synopsys® seeks to provide complete and accurate copyright and licensing information for 
each FOSS package, Synopsys® does not represent or warrant that the following information is complete, 
correct, or error-free. SOFTWARE recipients are encouraged to (a) investigate the identified FOSS packages 
to confirm the accuracy of the licensing information provided herein and (b) notify Synopsys® of any 
inaccuracies or errors found in this document so that Synopsys® may update this document accordingly. 

Certain FOSS licenses (such as the GNU General Public Licenses, GNU Library/Lesser General Public 
Licenses, Affero General Public Licenses, Mozilla Public Licenses, Common Development and Distribution 
Licenses, Common Public License, and Eclipse Public License) require that the source code corresponding 
to distributed FOSS binaries be made available to recipients or other requestors under the terms of the same 
FOSS license. Recipients or requestors who would like to receive a copy of such corresponding source code 
should submit a request to Synopsys® by post at:

Synopsys

Attn: Open Source Requests

700 East Middlefield Road

Mountain View, CA 94043

Please provide the following information in all submitted FOSS requests:

• the FOSS packages for which you are requesting source code; 

• the Synopsys® product (and any available version information) with which the requested FOSS 
packages are distributed; 

• an email address at which Synopsys® may contact you regarding the request (if available); and 

• the postal address for delivery of the requested source code. 
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FOSS Package Notices

Libpng 1.6.3

Project homepage: http://libpng.org

Project license: http://libpng.org/pub/png/src/libpng-LICENSE.txt 

This copy of the libpng notices is provided for your convenience. In case 
of any discrepancy between this copy and the notices in the file png.h 
that is included in the libpng distribution, the latter shall prevail.

COPYRIGHT NOTICE, DISCLAIMER, and LICENSE:

If you modify libpng you may insert additional notices immediately 
following this sentence.

This code is released under the libpng license.

libpng versions 1.2.6, August 15, 2004, through 1.6.3, July 18, 2013, are 
Copyright (c) 2004, 2006-2013 Glenn Randers-Pehrson, and are distributed 
according to the same disclaimer and license as libpng-1.2.5 with the 
following individual added to the list of Contributing Authors

 Cosmin Truta

libpng versions 1.0.7, July 1, 2000, through 1.2.5 - October 3, 2002, are 
Copyright (c) 2000-2002 Glenn Randers-Pehrson, and are distributed 
according to the same disclaimer and license as libpng-1.0.6 with the 
following individuals added to the list of Contributing Authors

 Simon-Pierre Cadieux Eric S. Raymond Gilles Vollant

and with the following additions to the disclaimer:

 There is no warranty against interference with your enjoyment of the 
library or against infringement. There is no warranty that our efforts or 
the library will fulfill any of your particular purposes or needs. This 
library is provided with all faults, and the entire risk of satisfactory 
quality, performance, accuracy, and effort is with the user.

libpng versions 0.97, January 1998, through 1.0.6, March 20, 2000, are 
Copyright (c) 1998, 1999 Glenn Randers-Pehrson, and are distributed 
according to the same disclaimer and license as libpng-0.96, with the 
following individuals added to the list of Contributing Authors:

 Tom Lane Glenn Randers-Pehrson Willem van Schaik

libpng versions 0.89, June 1996, through 0.96, May 1997, are Copyright 
(c) 1996, 1997 Andreas Dilger Distributed according to the same 
disclaimer and license as libpng-0.88, with the following individuals 
added to the list of Contributing Authors:

 John Bowler Kevin Bracey Sam Bushell Magnus Holmgren Greg Roelofs Tom 
Tanner

http://libpng.org
http://libpng.org/pub/png/src/libpng-LICENSE.txt
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libpng versions 0.5, May 1995, through 0.88, January 1996, are Copyright 
(c) 1995, 1996 Guy Eric Schalnat, Group 42, Inc.

For the purposes of this copyright and license, "Contributing Authors" is 
defined as the following set of individuals:

 Andreas Dilger Dave Martindale Guy Eric Schalnat Paul Schmidt Tim Wegner

The PNG Reference Library is supplied "AS IS". The Contributing Authors 
and Group 42, Inc. disclaim all warranties, expressed or implied, 
including, without limitation, the warranties of merchantability and of 
fitness for any purpose. The Contributing Authors and Group 42, Inc. 
assume no liability for direct, indirect, incidental, special, exemplary, 
or consequential damages, which may result from the use of the PNG 
Reference Library, even if advised of the possibility of such damage.

Permission is hereby granted to use, copy, modify, and distribute this 
source code, or portions hereof, for any purpose, without fee, subject to 
the following restrictions:

1. The origin of this source code must not be misrepresented.

2. Altered versions must be plainly marked as such and must not be 
misrepresented as being the original source.

3. This Copyright notice may not be removed or altered from any source or 
altered source distribution.

The Contributing Authors and Group 42, Inc. specifically permit, without 
fee, and encourage the use of this source code as a component to 
supporting the PNG file format in commercial products. If you use this 
source code in a product, acknowledgment is not required but would be 
appreciated. 

A "png_get_copyright" function is available, for convenient use in 
"about" boxes and the like:

 printf("%s",png_get_copyright(NULL));

Also, the PNG logo (in PNG format, of course) is supplied in the files 
"pngbar.png" and "pngbar.jpg (88x31) and "pngnow.png" (98x31).

Libpng is OSI Certified Open Source Software. OSI Certified Open Source 
is a certification mark of the Open Source Initiative.

Glenn Randers-Pehrson glennrp at users.sourceforge.net July 18, 2013
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HDF5 1.8.11

Project homepage: https://www.hdfgroup.org/

Project license: 

Copyright Notice and License Terms for HDF5 (Hierarchical Data Format 5) 
Software Library and Utilities 
------------------------------------------------------------------------

HDF5 (Hierarchical Data Format 5) Software Library and Utilities 
Copyright 2006-2013 by The HDF Group.

NCSA HDF5 (Hierarchical Data Format 5) Software Library and Utilities 
Copyright 1998-2006 by the Board of Trustees of the University of 
Illinois.

All rights reserved.

Redistribution and use in source and binary forms, with or without 
modification, are permitted for any purpose (including commercial 
purposes) provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, 
this list of conditions, and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright 
notice, this list of conditions, and the following disclaimer in the 
documentation and/or materials provided with the distribution.

3. In addition, redistributions of modified forms of the source or binary 
code must carry prominent notices stating that the original code was 
changed and the date of the change.

4. All publications or advertising materials mentioning features or use 
of this software are asked, but not required, to acknowledge that it was 
developed by The HDF Group and by the National Center for Supercomputing 
Applications at the University of Illinois at Urbana-Champaign and credit 
the contributors.

5. Neither the name of The HDF Group, the name of the University, nor the 
name of any Contributor may be used to endorse or promote products 
derived from this software without specific prior written permission from 
The HDF Group, the University, or the Contributor, respectively.

DISCLAIMER: THIS SOFTWARE IS PROVIDED BY THE HDF GROUP AND THE 
CONTRIBUTORS "AS IS" WITH NO WARRANTY OF ANY KIND, EITHER EXPRESSED OR 
IMPLIED. In no event shall The HDF Group or the Contributors be liable 
for any damages suffered by the users arising out of the use of this 
software, even if advised of the possibility of such damage. 

------------------------------------------------------------------------
----- ------------------------------------------------------------------
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Contributors: National Center for Supercomputing Applications (NCSA) at 
the University of Illinois, Fortner Software, Unidata Program Center 
(netCDF), The Independent JPEG Group (JPEG), Jean-loup Gailly and Mark 
Adler (gzip), and Digital Equipment Corporation (DEC).

------------------------------------------------------------------------

Portions of HDF5 were developed with support from the Lawrence Berkeley 
National Laboratory (LBNL) and the United States Department of Energy 
under Prime Contract No. DE-AC02-05CH11231.

------------------------------------------------------------------------

Portions of HDF5 were developed with support from the University of 
California, Lawrence Livermore National Laboratory (UC LLNL). The 
following statement applies to those portions of the product and must be 
retained in any redistribution of source code, binaries, documentation, 
and/or accompanying materials:

 This work was partially produced at the University of California, 
Lawrence Livermore National Laboratory (UC LLNL) under contract no. W-
7405-ENG-48 (Contract 48) between the U.S. Department of Energy (DOE) and 
The Regents of the University of California (University) for the 
operation of UC LLNL.

 DISCLAIMER: This work was prepared as an account of work sponsored by an 
agency of the United States Government. Neither the United States 
Government nor the University of California nor any of their employees, 
makes any warranty, express or implied, or assumes any liability or 
responsibility for the accuracy, completeness, or usefulness of any 
information, apparatus, product, or process disclosed, or represents that 
its use would not infringe privately- owned rights. Reference herein to 
any specific commercial products, process, or service by trade name, 
trademark, manufacturer, or otherwise, does not necessarily constitute or 
imply its endorsement, recommendation, or favoring by the United States 
Government or the University of California. The views and opinions of 
authors expressed herein do not necessarily state or reflect those of the 
United States Government or the University of California, and shall not 
be used for advertising or product endorsement purposes. 
------------------------------------------------------------------------
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AutoIt 3.3.14

Project homepage: https://www.autoitscript.com 

Project license: 

AutoIt

Author : Jonathan Bennett and the AutoIt Team

WWW : https://www.autoitscript.com/site/autoit/

Email : support at autoitscript dot com

 ________________________________________________________

END-USER LICENSE AGREEMENT FOR THIS SOFTWARE

This End-User License Agreement ("EULA") is a legal agreement between you 
(either an individual or a single entity) and the mentioned author of 
this Software for the software product identified above, which includes 
computer software and may include associated media, printed materials, 
and "online" or electronic documentation ("SOFTWARE PRODUCT"). By 
installing, copying, or otherwise using the SOFTWARE PRODUCT, you agree 
to be bound by the terms of this EULA. If you do not agree to the terms 
of this EULA, do not install or use the SOFTWARE PRODUCT.

SOFTWARE PRODUCT LICENSE

The SOFTWARE PRODUCT is protected by copyright laws and international 
copyright treaties, as well as other intellectual property laws and 
treaties. The SOFTWARE PRODUCT is licensed, not sold.

The definition of SOFTWARE PRODUCT does not includes any files generated 
by the SOFTWARE PRODUCT, such as compiled script files in the form of 
standalone executables.

1. GRANT OF LICENSE

This EULA grants you the following rights:

Installation and Use. You may install and use an unlimited number of 
copies of the SOFTWARE PRODUCT.

Reproduction and Distribution. You may reproduce and distribute an 
unlimited number of copies of the SOFTWARE PRODUCT either in whole or in 
part; each copy should include all copyright and trademark notices, and 
shall be accompanied by a copy of this EULA. Copies of the SOFTWARE 
PRODUCT may be distributed as a standalone product or included with your 
own product.
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Commercial Use. You may use the SOFTWARE PRODUCT for commercial purposes. 
You may sell for profit and freely distribute scripts and/or compiled 
scripts that were created with the SOFTWARE PRODUCT.

Reverse engineering. You may not reverse engineer or disassemble the 
SOFTWARE PRODUCT.

2. COPYRIGHT

All title and copyrights in and to the SOFTWARE PRODUCT (including but 
not limited to any images, photographs, animations, video, audio, music, 
text, and "applets" incorporated into the SOFTWARE PRODUCT), the 
accompanying printed materials, and any copies of the SOFTWARE PRODUCT 
are owned by the Author of this Software. The SOFTWARE PRODUCT is 
protected by copyright laws and international treaty provisions. 
Therefore, you must treat the SOFTWARE PRODUCT like any other copyrighted 
material.

MISCELLANEOUS

If you acquired this product in the United Kingdom, this EULA is governed 
by the laws of the United Kingdom. If this product was acquired outside 
the United Kingdom, then local law may apply.

Should you have any questions concerning this EULA, or if you desire to 
contact the author of this Software for any reason, please contact him/
her at the email address mentioned at the top of this EULA.

LIMITED WARRANTY

1. NO WARRANTIES

The Author of this Software expressly disclaims any warranty for the 
SOFTWARE PRODUCT. The SOFTWARE PRODUCT and any related documentation is 
provided "as is" without warranty of any kind, either express or implied, 
including, without limitation, the implied warranties or 
merchantability, fitness for a particular purpose, or non-infringement. 
The entire risk arising out of use or performance of the SOFTWARE PRODUCT 
remains with you.

2. NO LIABILITY FOR DAMAGES

In no event shall the author of this Software be liable for any damages 
whatsoever (including, without limitation, damages for loss of business 
profits, business interruption, loss of business information, or any 
other pecuniary loss) arising out of the use of or inability to use this 
product, even if the Author of this Software has been advised of the 
possibility of such damages. Because some states/jurisdictions do not 
allow the exclusion or limitation of liability for consequential or 
incidental damages, the above limitation may not apply to you.
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[END OF LICENSE]
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Floating license server (machine)

The computer onto which the license server software is installed. This computer will serve licenses to client 
machines upon request. The application itself need not be installed on the license server machine.

License server software

The software that regulates and protects application use; CODE V uses Sentinel RMS™. The license server 
software is installed on and runs as a service on the license server machine (or host). This service 
communicates with client machines over the network, and is responsible for checking out licenses to (and 
checking in licenses from) those client machines.

Client (machine)

The client, or client machine, is a computer that has CODE V installed on it, and is configured to use floating 
licenses (not fixed licenses).

Protected application

A single instance of CODE V, which is running on a client machine using a floating license.
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