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1
1Installing Saber

This document describes how to install Saber. It includes instructions for 
installing the Saber simulator, Saber HDL, and design environment on UNIX, 
Linux, and Windows platforms. Several other tools, including the CosmosScope 
waveform analyzer install with the Saber simulator.

 This document includes the following sections:
■ Preparing for Installation
■ Installing the Software on UNIX, Linux, and Windows
■ Invoking Saber on Windows
■ Setting Up the User Environment on UNIX and Linux
■ Verifying the Saber Installation on UNIX and Linux
■ Using Command Options
■ Troubleshooting Saber Licensing
■ Uninstalling the Software
■ Customer Support

Important:   

Install the latest version of Saber in a new folder. A common license can 
serve multiple versions of Saber.

Important:

The installation instructions in this document are the most up-to-date 
available at the time of production. However, changes might have occurred. 
For the latest installation information, see Saber release notes or 
documentation.
Saber® Installation Guide 1
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Preparing for Installation

The following points are prerequisites for the installation process.
■ If you have not already done so, retrieve your license keys from the 

SmartKeys Web page at 
http://solvnet.synopsys.com/smartkeys 

For detailed licensing information, see the Synopsys Licensing QuickStart 
Guide Web page at 
http://www.synopsys.com/keys

■ UNIX and Linux users: You must have root or administration privileges when 
installing licensing or tools in a restricted directory location. The installation 
script requires that the Bourne shell is available at /bin/sh.

■ Windows users: You must have administration privileges for installing and 
uninstalling the tool. In addition, you must close all running Saber 
applications (Sketch or Saber) before starting any Saber installation 
processes on Windows.

■ To download the software by electronic software transfer (EST), you must 
have Netscape Navigator 4.0 or later, Microsoft Internet Explorer 4.0 or later, 
or Mozilla 1.x or later.

■ Verify that your disk space is adequate. See Table 3 on page 6 for 
information on disk space requirements for each platform.

■ By default, the interface files that support MATLAB version 7.0 SP2 are 
installed. When you set the PATH environment variable, put the value for 
MATLAB in front of the other values. For example,

% PATH = C:\Program Files\MATLAB7.0\bin\win32; \
  C:\synopsys\version\ai_bin 

For access to other versions of MATLAB, see the INSTALL_README.wri 
file. For instructions about setting up other optional software (Cadence, 
Mentor, ModelSim, Verilog) see the Installing Saber Optional Software 
chapter

The Saber Release Notes provides information about changes in licensing, 
memory requirements, and supported platforms, as well as other 
enhancements and changes regarding the Saber tool. 
2 Saber® Installation Guide
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To read the release notes, 

1. Go to https://solvnet.synopsys.com/ReleaseNotes (If prompted, enter your 
user name and password. If you do not have a Synopsys user name and 
password, follow the instructions to register with SolvNet.)

2. Click Saber, then click the release you want in the list that appears at the 
bottom.

The Release Notes are in Portable Document Format (PDF) and require a PDF 
file reader to view and print them. 

Note:   

To view and print Saber documentation in Portable Document Format 
(PDF), you must have Adobe Acrobat Reader installed on your machine. To 
acquire the latest version of the Adobe Reader software, free of charge, go 
to http://www.adobe.com/ and click the Get Adobe Reader button. Follow 
the instructions on the Web page. 

The following sections describe:

Supported Platforms and Compilers

Disk Space and Memory Requirements

Installing the Software on UNIX, Linux, and Windows

Invoking Saber on Windows

Invoking Saber on UNIX and Linux

Troubleshooting Saber Licensing

Uninstalling the Software

Customer Support
Saber® Installation Guide 3
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Supported Platforms and Compilers 

Saber and Saber HDL are available on CD or by EST. Obtain the appropriate 
binary executable files for your operating system. Table 1 on page 4 lists the 
supported platforms for this release. Note that Saber HDL installs only on 
Solaris, Linux, and Windows platforms.

Note:   

For platform support for co-simulator interfaces and frameway interfaces 
and integrations, including Frameway Integration for Mentor Graphics and 
the Frameway Integration for Cadence, see the Saber Release Notes in 
SolvNet.

The Saber tools work with the Solaris operating system in combination with a 
FORTRAN, C, or C++ compiler. You will need one of these compilers if you are 
performing any of the following tasks:
■ Writing templates that call routines in a language other than the MAST 

modeling language (“foreign” routines)

Table 1 Supported Platforms, Operating Systems, and Keywords 

Platform Operating system Synopsys platform keyword

AMD   Opteron                        Red Hat Enterprise Linux v 4.51

1. Binary-compatible hardware platform or operating system. Note, however, that binary compatibility is 
not guaranteed.

amd64 (64-bit mode) 

HP PA-RISC 2.0 HP-UX 11.0, 11.11 (11i)1 hp32 (32-bit mode)

Sun SPARC Solaris 9, 101 (Solaris 9 with shared 
library patch 111711-12 or later)

sparcOS5 (32-bit mode)

IA-32 (x86) Red Hat Enterprise Linux v4, 51 (with 
update 5)

linux (32-bit mode)

IA-32 (x86) Windows XP Professional v2002 winXP

Windows 2000 SP3 or higher win2000
4 Saber® Installation Guide
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■ Writing user-defined batch measures
■ Providing user-defined windowing functions for a fast Fourier transform 

(FFT) analysis executed from within Saber
■ Installing the mixed-signal interface if you choose certain 

Verilog-XL options 

Table 2 shows the supported compilers for each platform. 

   

The following sections describe:

Disk Space and Memory Requirements

Installing the Software on UNIX, Linux, and Windows

Invoking Saber on Windows

Invoking Saber on UNIX and Linux

Troubleshooting Saber Licensing

Uninstalling the Software

Customer Support

Table 2 Compatible Operating System Compilers 

Operating system C C++ FORTRAN

HP 9000 PA-RISC 2.0 
(HP 8000) using 
HP-UX 11 (32-bit)

B.11.11.04 A.03.33 B.11.01.42

Red Hat Enterprise 
Linux 
(IA-32 (x86))

gcc 3.3.6 g++ 3.3.6 g77 3.3.6

Microsoft Windows 2000 
(32-bit)

MS Visual .NET MS Visual .NET Intel Visual Fortran 9.0 
with patch 24  

Sun Solaris (SPARC) 5.5 (Sun Studio 8) 5.5 (Sun Studio 8) 5.5 (Sun Studio 8)
Saber® Installation Guide 5
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Disk Space and Memory Requirements

The disk space requirement varies depending on the platform and the features 
selected for installation. Table 3 shows the maximum space required for 
installing all Saber features on a particular platform. Each CD also includes this 
information in the top-level INSTALL_README.wri file.

The following sections describe:

Installing the Software on UNIX, Linux, and Windows

Invoking Saber on Windows

Invoking Saber on UNIX and Linux

Troubleshooting Saber Licensing

Uninstalling the Software

Customer Support

Table 3 Saber Disk Space and Memory Requirements (in Megabytes) 

Platform Software 
(maximum)

Default temporary directory 
location

Temporary disk 
space from CD

Temporary disk 
space from EST

HP-UX 1060 /var/tmp 350 350

Sun Solaris 1470 /var/tmp 400 400

Linux 1500 /tmp 390 390

Windows 1310 %TEMP%
 or
C:\My Documents\temp

365 365
6 Saber® Installation Guide
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Installing the Software on UNIX, Linux, and Windows 

You can install Saber and Saber HDL using the common install GUI. To install 
Saber by using text commands, see Installing Synopsys Tools, available at 
http://www.synopsys.com/install

The following sections describe:

Installing the Software by EST

Installing the Software From a CD

Running the Installation Program

Installing the Software by EST

Download the Saber release to a temporary directory. You can obtain the latest 
Saber download instructions from the Release Library, which is accessible 
through SolvNet. 

To install the software on UNIX and Linux systems,

1. Double-click the downloaded file, or enter the file name at the command 
prompt.

2. Continue with the steps in Installing Synopsys Tools.

To install the software on Windows systems,

1. Locate and double-click the .exe file. For example, double-click

Saber_version_win.exe

where version is the release you are installing.

2. Continue with the steps in Installing Synopsys Tools. 

The following sections describe:

Installing the Software From a CD

Running the Installation Program
Saber® Installation Guide 7
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Installing the Software From a CD

Mounting the CD might require root access privileges. If you do not have root 
access privileges, see your system administrator for instructions on mounting 
the CD. For detailed instructions, see Installing Synopsys Tools.

To mount the CD on UNIX and Linux systems, 

1. Place the CD in the CD drive. 

Most UNIX and Linux systems will automatically mount the CD. If the CD 
does not mount, see Installing Synopsys Tools.

2. To invoke the installer, enter 

% /cdrom/saber_version_platform.bin

or

% cd your_cd_path; ./saber_version_platform

3. Continue with the steps in Installing Synopsys Tools.

To mount the CD on Windows systems,

1. Place the CD in the CD drive. 

The installation program should start automatically. If it does not, double-
click the setup.exe executable file, located at the root level of the CD. For 
example,

D:\saber_version_win.exe

where D is your CD drive.

2. Continue with the steps in “Running the Installation Program,” next.

The following section describes:

Running the Installation Program
8 Saber® Installation Guide
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Running the Installation Program

Make certain that any open applications are closed before proceeding with the 
installation. Also, consider disabling virus checking for the duration of the 
installation process, because virus checks can slow the installation process.

When the installation program begins, the Welcome screen appears. Answer 
the installation prompts and click Next to continue. If scroll bars appear in the 
panel, scroll to make sure you have reviewed all available information.

Only the path destination screen, which requires more explanation, is shown. 
(Note that selections shown in this screen are for demonstration purposes only 
and might not reflect the current product version.)

1. Read the Welcome Screen.

2. In the Installation Type window, select the type of installation you want to 
perform. 

UNIX and Linux: Select a Typical or Custom installation.

Windows: Select a Typical or Custom installation, or select a Network 
installation to establish network access from a client machine to previously 
installed products on a remote machine.

3. If you selected a Typical or Custom installation, enter a directory name that 
does not include spaces in the Destination box. You can also use the 
Browse button to select a directory.

4. (Windows only) If you have chosen to perform a network installation, create 
a network mapped drive to a remote machine on which the Saber software 
was previously installed. If not, skip to step 6.

5. (Windows only) Set up network access to a remote machine.

Note:

The Network installation option allows you to link to Saber applications, 
which are installed on other Windows machines. It is assumed that a stand-
alone Saber installation has already been performed on that machine.

Using Saber via a network installation is slow and results in poor 
performance when compared to a local installation.
Saber® Installation Guide 9
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• Enter the source path by using the previously created mapped drive, 
which resolves to the location where the ai_bin directory is located. For 
example, 

S:\Synopsys\Z-2007.03

where S: is your network mapped drive.

• Enter a destination path name to a location on the local host machine 
where a minimal set of files will be installed. In the Browse window, 
navigate to the directory you want, for example, Z-2007.03. Select this 
directory and click the Open button. The path to the Z-2007.03 directory 
is inserted in the Source box.

6. If you selected a custom installation, select the Saber features you want to 
install.
10 Saber® Installation Guide
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7. You will see a screen that asks you to wait while the disk space is being 
verified. Then the summary information screen appears. This screen 
summarizes the selections you have made and the disk space 
requirements.

8. Wait while the products are installed.

While files are being copied, you can track the Installation progress in the 
progress bar. When the bar shows a 100 percent progress, a Release Notes 
dialog box opens. Click Yes to read the release notes, click No to continue. 
You must wait while the uninstall program is created. The final installation 
status is then displayed, with the message that the tool has finished 
installing.

If errors are displayed in the final installation status, see the install log for 
details. 

9. Click Finish to exit the installation program.

The following sections describe:

Invoking Saber on Windows

Invoking Saber on UNIX and Linux

Troubleshooting Saber Licensing

Uninstalling the Software

Customer Support

Invoking Saber on Windows

Beginning in December 2005, regardless of which version of Saber you are 
installing, you must use Synopsys Common Licensing 10.9.1 or later, which 
requires only a single license daemon, snpslmd. For additional information, 
see Installing Synopsys Tools.

To run Saber on Windows platforms, 

1. Check that your SNPSLMD_LICENSE_FILE, LM_LICENSE_FILE, or 
another tool-specific license variable is set to a valid licensing server. If 
licenses are not available, the Saber Simulator will fail when invoked.

The port and host name variables correspond to the TCP port and license 
server host name specified in the SERVER line of the Synopsys license file. 
Saber® Installation Guide 11
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Each license file can contain licenses for many packages from multiple 
vendors. You can specify multiple license files by separating each entry with 
a semicolon (;).

2. Start the tool by going to Start > Programs > Synopsys > Saber version > 
Saber Simulator. 

The Saber window opens. 

3. To check the product version, choose Help > About Saber, and in the 
window that opens, click Copyright/Legal, then scroll to the bottom of the 
screen to view the version.

4. To exit Saber, choose File > Exit.

The following sections describe:

Invoking Saber on UNIX and Linux

Troubleshooting Saber Licensing

Uninstalling the Software

Customer Support

Invoking Saber on UNIX and Linux

This section explains how to invoke Saber on UNIX and Linux. The following 
sections describe:

Setting Up the User Environment on UNIX and Linux

Specifying the Executable File Location

Setting the SNPSLMD_LICENSE_FILE or LM_LICENSE_FILE Environment 
Variable

Verifying the Saber Installation on UNIX and Linux

Using Command Options

Setting Up the User Environment on UNIX and Linux

To set up the user environment, you must specify the location of the executable 
files and set the license environment variable.The directory containing the 
executable commands is located within the ai_bin directory in the install_home 
installation root.
12 Saber® Installation Guide
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The following sections describe:

Specifying the Executable File Location

Setting the SNPSLMD_LICENSE_FILE or LM_LICENSE_FILE Environment 
Variable

Verifying the Saber Installation on UNIX and Linux

Using Command Options

Specifying the Executable File Location

To set up a new Saber user, add the executable file to the path. 
■ If you are using the C shell, add the following line to the .cshrc file:

setenv PATH install_home/ai_bin:$PATH 

■ If you are using the Bourne, Korn, or Bash shell, add the following line to the 
.profile, .kshrc, or .bashrc file:

PATH=install_home/ai_bin:$PATH
export $PATH

The following sections describe:

Setting the SNPSLMD_LICENSE_FILE or LM_LICENSE_FILE 
Environment Variable

Verifying the Saber Installation on UNIX and Linux

Using Command Options

Setting the SNPSLMD_LICENSE_FILE or
LM_LICENSE_FILE Environment Variable

You must install the SCL software and define the SNPSLMD_LICENSE_FILE or 
LM_LICENSE_FILE before you can verify the Saber installation. 

For information about downloading and installing SCL and on setting the 
license variable, see Installing Synopsys Tools.
Saber® Installation Guide 13
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Specifying the Executable File Location

To set up a new Saber user, add the executable file to the path. 
■ If you are using the C shell, add the following line to the .cshrc file:

setenv PATH install_home/ai_bin:$PATH 

■ If you are using the Bourne, Korn, or Bash shell, add the following line to the 
.profile, .kshrc, or .bashrc file:

PATH=install_home/ai_bin:$PATH
export $PATH

The following sections describe:

Verifying the Saber Installation on UNIX and Linux

Using Command Options

Verifying the Saber Installation on UNIX and Linux

To verify the installation of the Saber tools,

1. Make sure you are in a directory where you have read/write privileges.

% cd $HOME

2. Invoke the tool by entering 

% saber 

or

% saberhdl

If the Saber tools are correctly installed, this command invokes the tool, 
displays the welcome screen, then opens the tool.
14 Saber® Installation Guide
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Specifying the Executable File Location

To set up a new Saber user, add the executable file to the path. 
■ If you are using the C shell, add the following line to the .cshrc file:

setenv PATH install_home/ai_bin:$PATH 

■ If you are using the Bourne, Korn, or Bash shell, add the following line to the 
.profile, .kshrc, or .bashrc file:

PATH=install_home/ai_bin:$PATH
export $PATH

The following section describes:

Using Command Options

Using Command Options 

You can install Saber on UNIX and Linux platforms by using the setup script 
command and on Windows platforms by invoking the setup.exe installation 
program. By default, the Saber installer invokes the GUI installation program on 
all platforms. If you want to install the software in silent mode or in the 
background, use the -silent command-line option, which is supported on all 
platforms. If you do not use the -silent option at the command line, any 
option you enter is reflected in the GUI.

The following options are available from the command line. Unless otherwise 
indicated, they are available for UNIX, Linux, and Windows systems.

Usage:setup [options]

-silent

Suppresses all graphics output. When you use the -silent option, Saber 
is installed in the default directory, C:\Synopsys\version.

-installdir destination_directory 

Installs files to a destination directory. The path name cannot include 
spaces.

-typical (default)

 Installs typical features.
Saber® Installation Guide 15
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-custom all | feature1 feature2 ...

Select one or more features to install: SaberSimulator, SaberSketch, 
CosmosScope, SaberHarness, ComponentLibrary, TemplateLibrary, 
eProductsDesigner, Cadence, and MentorGraphics.

Frameway features (Cadence, eProductsDesigner, and 
MentorGraphics) might not be available on all platforms.

-license port host1 [host2 host3] [license file] 

Windows

Sets up licensing services on Windows platforms. If you specify a license 
file, the file must already exist and have an absolute path name. If you don’t 
specify a license file, the default license file path name is used. You can 
change the default after installation.

The LM_LICENSE_FILE environment variable is set using the port and host 
information specified. If the LM_LICENSE_FILE environment variable 
already exists, only unique port and host information will be added. 

To set up or modify a local Windows license server, use the Macrovision 
LMTOOLS program, which you can access by choosing Start > Programs > 
Synopsys > Saber version > License Tool.
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To set or modify the LM_LICENSE_FILE environment variable, open the 
Control Panel and choose System > Environment (Windows NT) or System 
> Advanced > Environment Variables (Windows 2000 or later). You cannot 
use LMTOOLS to modify environment variables.

-is:tempdir temporary_directory

Specify an alternative location in which to store temporary files. On UNIX 
and Linux platforms, the default temporary directory might not contain 
enough free space to install the tool, causing the installer to terminate 
abnormally. 

The following sections describe:

Troubleshooting Saber Licensing

Uninstalling the Software

Customer Support

Troubleshooting Saber Licensing

If you see this licensing error,

“Could not get the license package SABER_SKETCH”

check the following settings:

UNIX: Check the LM_LICENSE_FILE environment variable to make certain it 
is set to 27000@hostname.

Windows: Check the location of the license file in the LMTOOLS Config service 
tab. If required, reread the license file in the Start/Stop/Reread dialog box.

The following sections describe:

Uninstalling the Software

Customer Support
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Uninstalling the Software

To uninstall the software on UNIX and Linux,
■ Execute the uninstall program, which is located in the  Install_home/_Saber 

directory, or delete the entire software directory. 

If you delete the directory, you must also delete the vpd.properties file 
located in your home directory.

To uninstall the software on Windows, 
■ From the Control Panel, select “Add/remove programs.”

or
■ Choose Start > Programs > Synopsys > Saber version > Uninstall.

or
■ Execute the uninstall program. For Saber, the uninstall program is located in 

the Install_home\_Saber directory. For example,

c:> install_home\_Saber\uninstall

The following section describes:

Customer Support

Customer Support

The following support centers are available: 

United States
■ Oregon office: 866-898-6700 or 503-547-6700, or send an e-mail message 

to saber-hotline@synopsys.com

International 
■ Germany: Telephone +49-89-99-320-0, fax +49-89-99-320-117, or e-mail 

saber-hotline-ge@synopsys.com 
■ France: Telephone +33 (0) 1 45 12 04 76, 

fax +33 (0) 1 45 12 07 07, or e-mail 
saber-hotline-fr@synopsys.com 

■ Sweden: Telephone +46 08 555 20220, fax +46 08 55520249,
or e-mail saber-hotline-swe@synopsys.com
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2Installing Saber Optional Software

This document describes how to install the optional Saber tools in the following 
sections:

■ Installing the Frameway Integration for Mentor Graphics
■ Troubleshooting a Frameway Integration for Mentor Graphics Installation
■ Installing the Saber Co-Simulation Interface With ModelSim
■ Installing the Frameway Integration for Cadence
■ Installing the Saber Co-Simulation Interface With Verilog
■ Setting Up the Software to Use a Remote System
■ Troubleshooting the Saber Co-Simulation Interface With Verilog Installation
■ Installing the Frameway Integration for eProduct Designer

Installing the Frameway Integration for Mentor Graphics

This section describes how to install the Frameway Integration for Mentor 
Graphics option, how to set up your environment, and what to do if problems 
occur.

The Frameway Integration for the Mentor Graphics Falcon Framework is loaded 
when you select MGC Frameway Integration on the installation tool menu as a 
part of the software installation procedure.

For the Saber netlister to function, you must load the CDP package when you 
install the Mentor Graphics software. The complete package name is

CDP V8 Ap SW
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Note:   

The SNPSLMD_LICENSE_FILE or LM_LICENSE_FILE license variable 
and the PATH environment variable must be defined before you run the 
Frameway Integration or Co-Simulation Interface option. 

% set PATH= (install_home/ai_bin $PATH) 

where install_home is the path to the Saber home directory.

(For detailed instructions on setting the license variable, see Installing 
Synopsys Tools, available at http://www.synopsys.com/support/installation/
install_guide.html.) 

Installing the Software

To install the Frameway Integration for Mentor Graphics option, 

1. Verify that $MGC_HOME is set, and test the Mentor Graphics products: 
Design Manager, Design Architect, and Design Viewpoint Editor.

• To invoke Design Manager, enter dmgr.

Exit Design Manager.

• To invoke Design Architect, enter da.

Exit Design Architect.

• To invoke Design Viewpoint Editor, enter dve.

Exit Design Viewpoint Editor.

2. Set up the Mentor Graphics gen_lib library.

a. Load the Mentor Graphics gen_lib library according to the instructions 
provided by Mentor Graphics.

b. Direct the software to the library by using one of the following methods:

Define MGC_GENLIB only in the location map file. Usually this 
definition will have already been set as part of the Design Architect 
installation procedure. For more information, see the Installing 
Mentor Graphics Software manual.

Include the location of the gen_lib library in the MGC_GENLIB 
environment variable. If you set this environment variable, you can 
also include an MGC_GENLIB entry in a location map file or not use 
a location map at all.
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3. Verify that the Saber simulator is installed and works correctly. 

4. Load the Frameway Integration software.

If you did not load the Frameway Integration for the Mentor Graphics Falcon 
Framework software at the time the Saber simulator was installed, do so 
now.

5. Add the license information to the license file. If needed, install the licenses 
for the Saber/Verilog Co-Simulation option and the Digital Simulation option.

6. Copy the Saber.dofile files and create symbolic links.

To take advantage of Design Architect and Design Viewpoint userware, you 
must copy the .dofile file from the installation directory to the Mentor 
Graphics MGC_HOME directory.

a. Make this location your current (working) directory. For example, on a 
Sun system enter

% cd $MGC_HOME/shared/etc/cust 

b. If the following directories do not already exist, create and change to 
them:

% mkdir dve
% cd dve

% mkdir userware
% cd userware 

% mkdir En_na

c. Create the following symbolic link:

% ln -s En_na default

d. Copy the .dofile files by entering

% cp $install_home/Saber/framework/falcon/ \
  userware/dve/setup_Saber.dofile default

e. Return to your home directory.

% cd

7. Create or modify environment variables in your startup file.

If you have scripts that automatically configure your environment, be aware 
that they can overwrite some of the environment variables mentioned in this 
step. You should place the variable declarations described in this step so 
that they are executed last.
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To automatically set up your environment variables, use a text editor to 
create the lines in your startup file.

UNIX: For the .cshrc file in the C shell,

• Enter the following lines in the .cshrc file after the setenv 
install_home and setenv MGC_HOME variable definitions:

setenv SABER_FALCON $install_home/Saber/framework/
falcon

setenv AMPLE_PATH $SABER_FALCON/userware
setenv MGC_TYPE_REGISTRY $SABER_FALCON/saber_rgy/

registry/ \ 
  type_registry/saber.rgy

setenv ANLG_IPC_PKG $install_home/Saber/framework/ \
falcon/ipc

setenv ANALOGY_SABER available
setenv SABER_MGC8_SYMBOLS $SABER_FALCON/symbols

The order of these lines in your .cshrc file is important.

Note:   

If AMPLE_PATH exists, add $SABER_FALCON/userware to the colon-
separated list of paths. Typically, this path is placed at the end of the list, 
but you must determine the appropriate order of the list (enter as all one 
line). If MGC_TYPE_REGISTRY already exists, just add 
$SABER_FALCON/saber_rgy/registry/type_registry/saber.rgy to the 
colon-separated list of paths. The following is an example of how these 
would be listed in your .cshrc file:

  setenv AMPLE_PATH $AMPLE_PATH:$SABER_FALCON/userware
 setenv MGC_TYPE_REGISTRY$MGC_TYPE_REGISTRY:$SABER_FALCON/ \
 saber_rgy/registry/type_registry/saber.rgy

For the .profile file in the Bourne shell,

• Enter the following lines in the .profile file after the install_home  and 
MGC_HOME environment variable definitions:
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SABER_FALCON="install_home/Saber/framework/falcon"
AMPLE_PATH="$SABER_FALCON/userware"
MGC_TYPE_REGISTRY="$SABER_FALCON/saber_rgy/registry/ 

\  
  type_registry/saber.rgy"
ANGL_IPC_PKG="install_home/Saber/framework/falcon/ \
  ipc" $SABER_FALCON/
ANALOGY_SABER=available
SABER_MGC8_SYMBOLS="$SABER_FALCON/symbols"
export SABER_FALCON
export AMPLE_PATH
export MGC_TYPE_REGISTRY
export ANLG_IPC_PKG
export ANALOGY_SABER
export SABER_MGC8_SYMBOLS

The order of these lines in your .profile file is important.

Note:   

If AMPLE_PATH or MGC_TYPE_REGISTRY already exist, add the 
paths specified above to the existing colon-separated list of paths. 
For example, the previous AMPLE_PATH and 
MGC_TYPE_REGISTRY entries could be replaced with the following:

AMPLE_PATH="$AMPLE_PATH:$SABER_FALCON/userware"
MGC_TYPE_REGISTRY="$MGC_TYPE_REGISTRY:  \

       $SABER_FALCON/saber_rgy/registry/type_registry/  \
    saber.rgy"

Windows: On Windows platforms, the Mentor environment variables 
can be set either in the profile file or from the Start menu.

• Add the following lines to the profile.ksh file:

export ANALOGY_SABER=available
export SABER_FALCON=install_dir/Saber/ \
       framework/falcon
export AMPLE_PATH=$SABER_FALCON/userware
export MGC_TYPE_REGISTRY=$SABER_FALCON/saber_rgy/ \
       registry/type_registry/saber.rgy 
export SABER_MGC8_SYMBOLS=$SABER_FALCON/symbols

If AMPLE_PATH or MGC_TYPE_REGISTRY is used for other applications, 
add the Saber paths to these variables as follows:
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export AMPLE_PATH="$AMPLE_PATH;$SABER_FALCON/ \
   userware"
export MGC_TYPE_REGISTRY="$MGC_TYPE_REGISTRY: \
   $SABER_FALCON/saber_rgy/registry/type_registry/ \ 
   saber.rgy"
MGC_TMPDIR=C:/tmp
ANLG_IPC_PKG=$SABER_FALCON/ipc

• Go to Start > Settings > Control Panel > System > Advanced tab > 
Environment Variables. In the User Variable pane, click New and add 
the following settings:

■ If AMPLE_PATH or MGC_TYPE_REGISTRY is already set for other applications, add the 
following Saber paths:

Important:   

Do not set the ANLG_IPC_PKG variable on Windows.

Variable name Variable value

ANALOGY_SABER available

SABER_FALCON install_dir\Saber\framework\falcon

AMPLE_PATH  %SABER_FALCON%\userware

MGC_TYPE_REGISTRY %SABER_FALCON%\saber_rgy\registry\type_registry\ 
    saber.rgy

SABER_MGC8_SYMBOLS %SABER_FALCON%\symbols

MGC_TMPDIR C:\tmp  

ANLG_IPC_PKG %SABER_FALCON%\ipc

Variable name Variable value

AMPLE_PATH old_AMPLE_PATH;%SABER_FALCON%\userware   

MGC_TYPE_REGISTRY old_MGC_TYPE_REGISTRY;%SABER_FALCON%\

                    saber_rgy\registry\type_registry\saber.rgy
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The following sections describe:

Verifying the Environment Variable Settings

Creating or Modifying a Location Map File

Loading the Saber and CosmosScope Icons

Verifying the Installation

Verifying the Environment Variable Settings

The environment variables described in the previous steps must be set for 
noninteractive invocations of /bin/csh, as well as interactive invocations of 
whatever shell you normally use. You cannot depend on noninteractive shells 
inheriting the environment from interactive shells in either Design Architect or 
Design Manager.

To ensure that the environment variables are correctly set,

1. Source your .cshrc file, create a new shell, or log out and log in.

2. To determine whether the environment is set correctly for interactive shells, 
enter

% printenv

3. View the results to verify each environment variable that was described in 
Step 7 on Installing the Software on page 20. Note that the variables are 
expanded to their absolute paths.

4. To determine whether the environment is set correctly for a noninteractive C 
shell, complete the following steps:

a. Using a text editor, create a file called my_csh_env in your current 
directory containing the following lines:

#!/bin/csh
printenv > analogy_csh_env

MGC_TYPE_REGISTRY old_MGC_TYPE_REGISTRY; \
 %SABER_FALCON%\saber_rgy\registry\type_registry \   
 \saber.rgy

b. Make the file executable by entering the following command at the shell 
prompt:

% chmod 777 my_csh_env

c. To invoke Design Architect, enter
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% da

d. When the Design Architect session window appears, move the cursor 
into the session window area, enter the following command: 

$system("my_csh_env")

e. Exit Design Architect.

The previous steps create the analogy_csh_env file, which contains a 
list of all environment variables in the noninteractive shell created with 
the invocation of Design Architect. Check this file to ensure that the 
environment variables are set correctly.

The following sections describe:

Creating or Modifying a Location Map File

Loading the Saber and CosmosScope Icons

Verifying the Installation

Creating or Modifying a Location Map File

The MGC_LOCATION_MAP variable points to a location map file. You need to 
modify that location map file. However, if you cannot modify the file (or don’t 
want to), you can copy it to your local directory, modify it, and change the 
MGC_LOCATION_MAP variable to point to your local copy. If the variable is not 
defined, or if you do not know where to find a location map file, ask your system 
administrator. The MGC_LOCATION_MAP variable must point to the location 
map file for both interactive and noninteractive shells, as outlined in the 
previous section. 

It is not sufficient to simply change the variable for your current shell. If you are 
not using a location map, set MGC_LOCATION_MAP to NO_MAP.

To create or modify a location map file,

1. If you need to create a location map file rather than copy an existing one, 
place the following lines at the beginning of the file:

MGC_LOCATION_MAP_2
(blank line)

2. Add the following soft prefixes to the location map file that you are either 
creating or modifying:
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$SABER_MGC8_SYMBOLS
(blank line)
$SABER_FALCON
(blank line)

The Mentor Graphics environment requires that these entries be present in 
the location map file to indicate that they are soft paths. You do not have to 
specify hard paths for the location map entries because you already defined 
them as environment variables, which override the corresponding location 
map entries. However, if you prefer, you can omit the environment variable 
specifications and instead specify the hard paths in the location map entries. 
In either case, the location map entries must be included in the location map 
file.

If you are using the Mentor Graphics Board Station products, a blank line 
after the soft prefix name in the location map file can cause a fatal error. 
Instead, you must specify a hard path for each soft prefix in the location map 
file (except for the MGC_LOCATION_MAP_2 entry).

3. Initialize the startup file by logging out and logging back in.

The installation of the Frameway Integration software is now complete. 

The following sections describe:

Loading the Saber and CosmosScope Icons

Verifying the Installation

Loading the Saber and CosmosScope Icons

To load the Saber and CosmosScope icons, 

1. Start Design Manager by using the following command:

% dmgr

When Design Manager is running, place the pointer in the Tools window and 
click to activate the menu bar for the Tools window. 

2. Add the Saber toolbox.

a. Select the Toolbox window by clicking in the border of the window.

b. Use the right mouse button to choose “View toolboxes.” 

c. When the $MGC_HOME/toolbox icon appears, choose Edit > Add 
Toolbox. A prompt bar appears on the lower-left side of the Toolbox 
window. 
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d. Enter the following full path in the prompt bar and click OK: 

saberfalcon/saber_rgy/toolbox

In the preceding command, saberfalcon is the full path name to the 
place where the $SABER_FALCON environment variable resides. You 
must either specify a hard path or $SABER_FALCON must be defined in 
the location map. If $SABER_FALCON is defined in the location map, you 
can use this soft name in the prompt bar entry. 

A second toolbox named saberfalcon/saber_rgy/toolbox should now 
appear in the Toolbox window.

3. Make sure the Saber and CosmosScope icons are visible in the Tools 
window.

If the Tools window is not present inside the Design Manager window, 
choose View > Tools. The icons for the Saber simulator and CosmosScope 
should now be present in the Tools window, though you might have to scroll 
through the window to find them.

4. Exit Design Manager.

The following section describes:

Verifying the Installation

Verifying the Installation

To verify that the Frameway Integration for Mentor Graphics is installed 
correctly, 

1. Copy the $install_home/test/install/mentor directory to a local location.

2. Navigate to the newly created mentor directory.

3. Set the $SABER_FALCON environment variable to point to your local copy 
of the mentor directory. For example, if you are using the C shell, enter

% setenv SABER_EXAMPLE your_path/mentor
4. Invoke Design Architect by entering the following command:

% da

5. In Design Architect, click the Open Sheet icon to open the Open Sheet 
dialog box.

6. In the Open Sheet dialog box, click the Navigator button, and in the resulting 
List box, select the component you want to install. 
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The path to the component appears in the Component Name box of the 
Open Sheet dialog box. 

7. In the Open Sheet dialog box, click OK.

8. Choose Check > Sheet. Close or minimize the “Check sheet” summary.

9. Choose File > Save Sheet. 

10. Choose Saber > Netlist > Show Netlister Transcript. 

You will be able to watch the netlister process in the resulting Netlister 
Transcript window.

11. Choose Saber > Netlist > Start Netlister. 

This starts the netlister. 

12. After the netlist process has finished without any errors, close the Netlister 
Transcript window.

13.  Invoke Saber Guide by choosing Saber > Start Saber Guide.

14. Open the Saber Guide Transcript window by clicking the cmd Simulation 
Transcript icon.

15. In the Saber Guide Transcript window, execute the following command:

<install.scs

The install.scs test program starts a simulation of a test circuit and then 
loads the resultant plot files into CosmosScope.

Note:   

The signals are not plotted in the graph window. To plot the same 
signals in the graph window, use the scope plot command in the 
install.scs command script.

16. If the commands that were executed by the install.scs script produced no 
errors, the communication between the Mentor Graphics environment and 
the Saber simulator is good. If you want to complete the test as was done in 
checking the Saber simulator installation, see steps 7 and 8.

17. Exit Saber and Design Architect.
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The following sections describe:

Troubleshooting a Frameway Integration for Mentor Graphics Installation

Installing the Saber Co-Simulation Interface With ModelSim

Installing the Frameway Integration for Cadence

Installing the Saber Co-Simulation Interface With Verilog

Troubleshooting the Saber Co-Simulation Interface With Verilog Installation

Setting Up the Software to Use a Remote System

Installing the Frameway Integration for eProduct Designer

Troubleshooting a Frameway Integration for
Mentor Graphics Installation

If you followed the steps in the previous section, the environment for running 
the Frameway Integration for the Mentor Graphics Falcon Framework should be 
set up correctly. However, other factors can affect the operation of the software. 
This section describes potential problems and suggests solutions.

PROBLEM 1

A schematic window is open and active but there is no Saber menu item in the 
menu bar, no Saber Parts Gallery menu item, and no Saber or CosmosScope 
icons in the palette.

Solution A

The ANALOGY_SABER environment variable is not set to the value available. It 
is also possible that either the variable or the value is misspelled. Setting this 
environment variable correctly causes the Saber menu item to appear in the 
menu bar even if the software has not been loaded. 

Solution B

If the ANALOGY_SABER environment variable is set correctly, other causes 
might be that you executed an old version of Mentor Graphics software or that 
some other third-party userware redefined the menu bar. If fixing these 
potential causes does not solve your problem, contact Customer Support.

PROBLEM 2

A schematic window is open and active and there is a Saber menu item in the 
menu bar, but there is no pull-down menu associated with it.
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Solution 

The userware has not been loaded into Design Architect. Enter the following 
command:

% ls $SABER_FALCON/userware

Check that the des_arch, base, and dve directories are listed and that there is 
something in each of these directories. Also, make sure that the AMPLE_PATH 
environment variable contains the exact path that $SABER_FALCON/userware 
resolves to. For information on setting AMPLE_PATH, see Step 7 in Installing 
the Software on page 20.

PROBLEM 3

The first time you open a schematic window, error messages appear in the 
Design Architect transcript window stating that $load_library failed in the 
ipc.ample file.

Solution A

Check that the $ANLG_IPC_PKG/lib/ample_ipc.dl file exists. If not, check the 
ANLG_IPC_PKG environment variable setting, which is defined in 
$install_home/bin/ai_setupmgc and aisetupmgc_csh.

Solution B

The library mentioned in the $load_library message must have execute 
permissions. Check the permissions of $ANLG_IPC_PKG/lib/ample_ipc.dl to 
ensure that read and execute permissions exist for everybody.

PROBLEM 4

A netlist fails after you chose Saber > Netlist or Saber > Start Saber Guide and 
ran an analysis.

Solution A

If a transcript window appears and shows the error message, fix the problem as 
described. The transcript window shows the actual output of the current run.

Solution B

Check the transcript window carefully for the following message:

dvetos.exe: command not found

Check that your path environment variable points to the install_home/ai_bin 
directory.
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PROBLEM 5

The palette icons associated with the Saber products appear as letters or 
numbers rather than pictures in Design Architect, or the Saber simulator tool 
icons (Saber and CosmosScope) do not appear in the Design Manager Tools 
window.

Solution

HP Platforms

Verify that the $SABER_FALCON/saber_rgy/registry/fonts directory is not 
empty. If the fonts directory is not empty, you might be using the wrong fonts. 
Before rebuilding the fonts, you must remove everything in the fonts directory. If 
.snf files were in this directory before, create X11R4 fonts. If .pcf files were in 
this directory before, create X11R5 fonts. 

All Platforms

If the fonts still do not work after you rebuild them, execute the following 
commands: 

% xset fp+ $SABER_FALCON/saber_rgy/registry/fonts
% xset fp+ $MGC_HOME/registry/fonts 
% xset fp rehash

This procedure should get your workstation to recognize the fonts. If you still 
have problems, ensure that everyone has at least read and execute 
permissions on all of the directories identified by the $SABER_FALCON/
saber_rgy/registry/fonts path.

The following sections describe:

Installing the Saber Co-Simulation Interface With ModelSim

Installing the Frameway Integration for Cadence

Installing the Saber Co-Simulation Interface With Verilog

Troubleshooting the Saber Co-Simulation Interface With Verilog Installation

Setting Up the Software to Use a Remote System

Installing the Frameway Integration for eProduct Designer
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Installing the Saber Co-Simulation Interface With ModelSim

Note:   

The SNPSLMD_LICENSE_FILE or LM_LICENSE_FILE license 
environment variable must be defined before you use a Frameway 
Integration or Co-Simulation Interface option. For detailed instructions on 
setting the license variable, see Installing Synopsys Tools.

Before you can correctly install the Saber/ModelSim interface, you must verify 
the proper installation and operation of the ModelSim software and the Saber 
software.

To correctly set up the Saber/ModelSim interface with the correct master-slave 
relationships, perform the following operations:
■ For Solaris:

If ModelSim is master, enter

% setenv SABER_MODELSIM install_home/Saber/ \
    bin/sabermti.so 
% set path=(install_home/ai_bin $path)
% setenv LD_LIBRARY_PATH:$install_home/ \
    Saber/bin

If Saber is master, enter

% setenv SABER_MODELSIM install_home/Saber/ \
    bin/sabermti.so

$PATH must include the path to the ModelSim executable files.
■ For HP-UX:

If ModelSim is master, enter

% setenv SABER_MODELSIM install_home/Saber/ \
    bin/sabermti.sl
% setenv SHLIB_PATH install_home/Saber/bin 
% set path=(install_home/ai_bin $path)

If Saber is master, enter 

% setenv SABER_MODELSIM install_home/Saber/ \
bin/sabermti.sl

$PATH must include the path to the ModelSim executables files.
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■ For Windows:

a. Open the Environment Variables dialog box. 

For example, on a Windows 2000 system, go to Start > Settings > 
Control Panel > System > Advanced > Environment Variables.

b. Set the SABER_MODELSIM variable to

install_home\Saber\sabermti.dll

c. If ModelSim is the master, add the following line to the PATH variable:

install_home\ai_bin;install_home\Saber\bin

d. PATH must include the path to the ModelSim executable files.

The following sections describe:

Installing the Frameway Integration for Cadence

Installing the Saber Co-Simulation Interface With Verilog

Troubleshooting the Saber Co-Simulation Interface With Verilog Installation

Setting Up the Software to Use a Remote System

Installing the Frameway Integration for eProduct Designer

Installing the Frameway Integration for Cadence

Note:   

The SABER_HOME variable and a license environment variable must be 
defined before you install a Frameway Integration or Co-Simulation Interface 
option. 

Set the SABER_HOME environment variable as follows: 

% setenv SABER_HOME install_home/Saber

To set the SNPSLMD_LICENSE_FILE or LM_LICENSE_FILE license 
environment variable, see Installing Synopsys Tools.
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Before you can correctly install the Frameway Integration for the Cadence 
Design II Environment, you must verify the proper installation and operation of 
the partner software and the Saber software. To make these checks,

1. Test the Design Framework II software installation.

a. Invoke Design Framework II by entering the appropriate command for 
your system. Your invocation command will be similar to one of the 
following examples: icms, ictb, msfb, or icds.

The Frameway Integration for Design Framework II is compatible with 
the Cadence Composer and Analog Artist 4.X.

b. Exit Design Framework II.

Note:   

If you are unable to invoke Design Framework II, see the 
appropriate Cadence installation manual for more information.

2. Verify that the Saber simulator is installed and works correctly.

3. Set the library environment variables.

Set or modify the path to your LD_LIBRARY_PATH (Sun) or  SHLIB_PATH 
(HP) variable in your .cshrc file. A script is provided to automate this 
procedure. Simply enter the following lines at the command-line prompt:

% ed ’s/$0/ai_setlibpath/’ $SABER_HOME/bin/ \
  ai_setlibpath > ! /tmp/my_setlibpath

% source /tmp/my_setlibpath

4. (Optional) If you will be using a partner simulator with the Saber simulator, 
verify that the Verilog simulator is installed for use as a partner simulator.

5. Load the Frameway Integration software.

If you did not load the Frameway Integration for the Cadence Design 
Framework II at the time the Saber simulator was installed, do so now.

6. Install the necessary license.

a. Add the license information to the license file.

b. If needed, install the licenses for the Saber/Verilog Co-Simulation option 
and the Digital Simulation option.

7. Create the directories.

You must create a directory named local in cadence standard directory/
tools/dfII and create several directories within the local directory.
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a. Make this directory your current (working) directory. For example, on a 
Sun system enter

% cd $cds_root/tools/dfII

b. Create this directory, if it does not already exist, as follows:

% mkdir local

c. Create the following directories in the local directory if they do not 
already exist:

% cd local
% mkdir hnl
% mkdir -p si/caplib
% cd si/caplib

d. Copy the following files to the caplib directory:

• Copy the si_saber_cds.il file to a Saber.il file in the caplib directory and 
change permissions, as follows:

% cp $SABER_HOME/framework/artist/skill/ \ 
si_saber_cds.il  cadence_standard_directory/ \
tools/dfll/local/si/caplib/Saber.il

% chmod 755 cadence_standard_directory/tools/dfll/ \ 
local/si/caplib/Saber.il

• Copy the si_saberHDL_cds.il file to a SaberHDL.il file in the caplib 
directory and change permissions, as follows:

% cp $SABER_HOME/framework/artist/skill/ \
si_saberHDL_cds.il  cadence_install_dir/ \
tools/dfll/local/si/caplib/SaberHDL.il

% chmod 755 cadence_install_dir/tools/dfll/ \
local/si/caplib/SaberHDL.il

e. Copy the following files to the hnl directory:

• Copy the hnl_saber_cds.il file to a Saber.il file in the hnl directory and 
change permissions, as follows:

% cp $SABER_HOME/framework/artist/skill/ \
hnl_saber_cds.il cadence_standard_directory/ \
tools/dfII/local/hnl/Saber.il

% chmod 755 cadence_standard_directory/tools/dfII/ \
local/hnl/Saber.il

• Copy the hnl_saberHDL_cds.il file to a SaberHDL.il file in the hnl 
directory and change permissions, as follows:
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% cp $SABER_HOME/framework/artist/skill/ \
 hnl_saberHDL_cds.il cadence_install_dir/ \
  tools/dfII/local/hnl/SaberHDL.il

% chmod 755 cadence_install_dir/tools/dfII/ \
  local/hnl/SaberHDL.il

8. Enter cd to return to your home directory.

9. Edit your cds.lib file to add symbol information.

The cds.lib file is a part of the Cadence Design Framework II software.

• Edit the cds.lib file to include the path to the Frameway symbols in the 
definition of the library search path. You do this by using ASCII files. For 
example,

DEFINE SaberLib $SABER_HOME/framework/artist/symbols/
SaberLib
DEFINE basic $CDS_HOME/tools/dfII/etc/cdslib/basic
INCLUDE /.../other/.../cds.lib

These files can call other cds.lib files so that system files can be resident 
in a location and referred to with an INCLUDE statement. Environment 
variables can be used as shown.

If the cds.lib file is in your local directory, it is used. Otherwise the ~/
cds.lib file is used. By using a local cds.lib file, you can set design-
specific search paths.

10. In the Cadence Design Framework II directory, create a MAST file 
containing initial configuration information. 

a. To create the file, use an ASCII editor, such as vi, that does not insert 
formatted text and enter
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//Revision 4
//NOTE
// Default template for MAST
// Note:
// Please remember to replace Top Cell
// Library, Cell, and View fields with the 
// actual names used by your design.
//END_NOTE

config mast;
design myLib.myCell:myView;

viewlist mast, schematic, symbol;
stoplist mast, symbol;

endconfig

b. Place the file in the following directory:

$CDS_HOME/tools/dfII/local/hierEditor

c. Name the file MAST and save it.

11. Copy the .artistSaberDefaults.il file. 

The .artistSaberDefaults.il file sets the defaults for menus and dialog boxes 
in Design Framework II. You can copy this file into your home directory and 
modify it to set the defaults you prefer for general use, or you can copy it into 
a particular project directory and then modify it to set the defaults to be used 
for that project. 

If more than one .artistSaberDefaults.il file exists on your system, the 
.artistSaberDefaults.il file in your current (working) directory is used if it 
exists. If not, the .artistSaberDefaults.il file in your home directory is used.

a. Make your home directory or a project directory your working directory.

b. To copy the file to your working directory, enter

% cp $SABER_HOME/framework/artist/ dotfiles/
.artistSaberDefaults.il .

Enter the code all on one line. The space and period at the end are 
important.

c. To change the default working directory for the Cadence Design 
Framework II software, which is set by the .artistSaberDefaults.il file, 
edit the file as follows:
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System administrators: To change the sitewide .artistSaberDefaults.il 
file, edit the file in $SABER_HOME/framework/artist/dotfiles.

Individual users: Edit your local copy of the .artistSaberDefaults.il file. 

• Set the saber_simRunDir template to point to the specific directory you 
want.

Or you can set

saber_simRunDir = getWorkingDir()

• Choose Saber > Set Working Directory and specify the directory you 
want.

• Use a UNIX environment variable called SABER_DEFAULT to set the 
path to the .artistSaberDefaults.il file.

If this path is set and the file is present, this file will be loaded. Otherwise 
the .artistSaberDefaults.il file will be loaded from the home directory or 
the working directory. For example, suppose you set the variable as 
follows: 

setenv SABER_DEFAULT /homes/myfile/latest

If an .artistSaberDefaults.il file exists in /homes/myfile/latest, it will be 
used instead of any other files present on your system. 

12. Load the new ~/.cdsinit file.

To access the integration to Cadence 5.0 or 5.1, you need to create a new 
.cdsinit file and install it in each user’s home directory. Use a text editor, such 
as vi, that does not insert formatted text. 

The contents of the .cdsinit file for this release are different from the contents 
in previous versions. An example of the new file contents follows:
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load(strcat(getShellEnvVar("install_home")\
"/framework/artist/skill/analogy.il "))

;
load(strcat(getShellEnvVar("install_home")\
"/framework/artist/skill/analogyReg.il”));
;
load(strcat(getShellEnvVar("install_home")\

"/framework/artist/skill/viewgen.il "))
;
analogy_menu_creation()
;
printf( "Done with startup

initialization.\n" )

The analogyReg.il and viewgen.il files are necessary only if you are using 
the Frameway Integration for Cadence text views feature. These files are 
used to register the MAST view type. The MAST views must be registered 
before you can create them.

13. Register the MAST views by performing the following steps:   

a. Go to the data.reg file, which is located at 

$SABER_HOME/framework/artist/skill 

b. Do one of the following: 

• Put data.reg into the home directory. 

• Follow the instructions in data.reg to split it into these files:

cds_install/share/cdssetup/registry/data/mast.reg

cds_install/share/cdssetup/registry/data/anlg_verilog.reg

cds_install/share/cdssetup/registry/data/snps_vhdlams.reg

cds_install/share/cdssetup/registry/tool/mastEditor.reg

cds_install/share/cdssetup/registry/tool/anlg_verilog.reg

cds_install/share/cdssetup/registry/tool/snps_vhdlams.reg

c. Load the analogyReg.il and viewgen.il files with analogy.il. Add a line to 
your .cdsinit file that will load all three files.

The viewgen.il file and the analogyReg.il file, which contains the trigger 
functions, are located at 

$SABER_HOME/framework/artist/skill 
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d. To create a MAST view that uses the trigger functions found in 
analogyReg.il, follow the procedures on creating text views in Cadence 
in the Analyzing Designs Using Saber for the Cadence Design 
Framework II manual. 

14. Verify that the menus have been installed correctly, and complete the 
installation.

a. Copy the $SABER_HOME/test/install/cadence directory to a local 
location.

b. Edit your cds.lib file to include the path of the cadence/install library.

c. Invoke Design Framework II by entering the appropriate command for 
your version of the software (for example, icde, icds, icms, asicfe, 
layout, layoutPlus, icca, asicpr, or icfb).

The Saber menu item should appear on the menu bar in the schematic 
window.

d. Choose File > Open. The Open File dialog box appears.

e. In the Open File dialog box, 

• Select Library Name > install.

• Then select Cell Name > install.

• Then select View Name > schematic. 

• Click OK.

f. The schematic window should appear with no errors. Check and save 
the design if necessary.

g. In the schematic window, 

• Choose Saber > Set Working Directory. 

• In the resulting Project Information dialog box, check that the Project 
Directory box is set to your_path/cadence. 

• Click OK.

h. In the schematic window, select Saber > Netlist > Start Netlister. 

This starts the netlister. A simulation window appears that contains the 
netlister transcript. 

i. After the netlist process has finished without errors, close the simulation 
window.

j. Invoke Saber Guide by choosing Saber > Start Saber Guide. 

The design is automatically loaded in Saber.
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k. Open the Saber Guide transcript window by clicking the Simulation 
Transcript icon.

l. In the Saber Guide transcript window, choose File > Load Command 
File. 

m. Navigate to your_path/cadence and load the install.scs file. 

This will execute the commands in the install.scs file. The install.scs test 
program starts a simulation of a test circuit and then loads the resultant 
plot files into CosmosScope.

If the commands that were executed by the install.scs script produced 
no errors, the communication between the Cadence Design Framework 
II and the Saber simulator is good. 

n. Exit Saber and Design Framework II.

The following sections describe:

Installing the Saber Co-Simulation Interface With Verilog

Troubleshooting the Saber Co-Simulation Interface With Verilog Installation

Setting Up the Software to Use a Remote System

Installing the Frameway Integration for eProduct Designer

Installing the Saber Co-Simulation Interface With Verilog 

Note:   

The SNPSLMD_LICENSE_FILE or LM_LICENSE_FILE license variable 
must be defined before you install a Frameway Integration or Co-Simulation 
Interface option. See Installing Synopsys Tools.

To simulate mixed-signal designs by using Verilog-XL as a partner simulator 
with the Saber simulator, you will need the following licenses:
■ Licenses for the Saber/Verilog Co-Simulation Interface (SABER/

VERILOG_MM)
■ A license from Cadence Design Systems for the Verilog-XL simulator

To build the Verilog executable file, you need to run the vconfig utility provided 
by Cadence. 

Set or modify the path to your LD_LIBRARY_PATH (Sun) or your SHLIB_PATH 
(HP) variable in your .cshrc file. 
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See the instructions for linking Verilog executable files in the Cadence 
documentation.

To install your Saber/Verilog software,

1. Install the software.

The Saber/Verilog Co-Simulation Interface software is loaded at the same 
time you load the Saber integrated suite of products.

2. Install the licenses.

• If you have not yet installed a license file for your software, you can 
install the license for the SABER/VERILOG_MM option as a part of the 
software installation procedure. 

• If you have already installed a license file for your software, update that 
file by adding the SABER/VERILOG_MM license.

3. Verify that the Saber simulator is installed and works correctly. 

4. Install the Verilog-XL simulator license.

Obtain a Verilog-XL simulator license from Cadence Design Systems, and 
complete any installation instructions provided with the license.

5. Test that the Verilog-XL simulator is installed correctly.

• Invoke the Verilog-XL simulator by entering the appropriate command 
for your system.

If you cannot invoke the Verilog-XL simulator, see the appropriate 
Cadence Design Systems installation manual for more information.

• Exit the Verilog-XL simulator.

6. (Optional) Create a configuration file for socket communication. 

By default, pipe communication mode is used with the Saber simulator. If 
you want to use socket communication with Saber Guide, you must create 
a config.vmx file as follows:

a. Copy the $install_home/bin/config.vmx file to your working directory.

If you save the config.vmx file to a directory other than your working 
directory, you must modify your $install_home/bin/verilog.scf file 
accordingly.

b. Make no other changes to the verilog.scf file.
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The version of the verilog.scf file provided with the software must be 
used when you use the Saber/Verilog software. Check that no other 
versions are present in the data search path ahead of this file.

7. Create the Verilog executable file.

Follow Cadence instructions for invoking vconfig. The instructions likely 
involve adding a directory to your PATH environment variable, for example, 
$CDS_ROOT/tools/bin.

a. When vconfig asks, “What do you want to name the Verilog_XL target?,” 
use the default: verilog.

b. When vconfig asks, “Do you want to include Verilog Mixed-Signal 
Interface?,” answer YES.

c. When vconfig asks for the names of additional files to be loaded, enter 
a single period (.).

d. Create the Verilog executable file by entering 

% ai_make_verilog

For more information about the command, enter

% ai_make_verilog -h

8. Install the Verilog-XL executable file in the desired directory.

9. (Optional) Change the invocation name for the Saber/Verilog simulator.

You can set the invocation name verilog to an ASCII string of your choosing 
in the invocation_name.scf file.

a. Use an ASCII text editor to open the $install_home/bin/
invocation_name.scf file. 

b. Change the invocation name item from verilog to an ASCII string (for 
example, verilog.scf).

The following section describes:

Troubleshooting the Saber Co-Simulation Interface With Verilog Installation

Setting Up the Software to Use a Remote System

Installing the Frameway Integration for eProduct Designer
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Troubleshooting the Saber Co-Simulation Interface
With Verilog Installation 

This section describes a series of potential problems and suggests solutions.

PROBLEM 1

You get an error while creating the Verilog executable file. 

Solution A

Usually, this error is due to missing or incorrect versions of the C or C++ 
compilers.

Solution B

Some releases of Cadence's vconfig might produce a script that, when run, 
produces undefined symbols:

ld: Undefined symbol
bcopy
getdtablesize
getwd

These symbols are undefined because a Cadence library, virtuous.a, is missing 
from the vconfig output script. The library will be included if you answer the 
vconfig questions in a particular way. In general, those questions that have v as 
their default answer result in the inclusion of virtuous.a. Contact Cadence for 
details.

PROBLEM 2

When you attempt to operate remotely, the error message “remote_host_name: 
remote_host_name: cannot open” is displayed.

Solution 

The restricted shell version of the rsh command was executed instead of the 
remote shell version. Change your PATH environment variable to include the 
path to the remote shell version of the rsh command. This executable file is 
typically located in either /usr/ucb or /usr/bin. This directory should appear in 
the search path ahead of any directories containing, or pointing to, the 
restricted shell version of the rsh command.
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PROBLEM 3

When you attempt to operate remotely, the error message “permission denied” 
is displayed.

Solution

Complete the following steps:
■ Log in to the remote system.
■ Create or modify a file named .rhosts in your home directory on the remote 

system. Include in the file a line that contains the name of your local system. 
To view man page information about the .rhosts file, enter one or both of the 
following commands:

man login
man rsh

PROBLEM 4

You are unable to start Verilog-XL from the Saber simulator.

Solution A

The Verilog-XL executable file does not have execute permission. Change the 
permission on the executable file, using the command

% chmod +x verilog_pathname 

where verilog_pathname is the path to Verilog-XL, including the executable file. 

Solution B

The Verilog-XL executable file is not found in the PATH variable. Change the 
path definition to include the directory where the Verilog-XL executable file 
resides, as follows:

set PATH = (verilog_directory $PATH)

where verilog_directory is the path to the directory containing the Verilog-XL 
executable file.
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PROBLEM 5

Verilog-XL starts but exits immediately with the message

***The partner simulator exited unexpectedly***

Solution A

Verilog-XL cannot find the license file. Examine the Verilog-XL output file 
verilog.log. Look for a line in the log file similar to this one:

Error! ERROR (LM -24): can’t find license file.

If such an error is found, make sure the license variable  
(SNPSLMD_LICENSE_FILE or LM_LICENSE_FILE) points to the appropriate 
license file. Modify the environment variable if necessary. For example,

setenv LM_LICENSE_FILE "...:verilog_license_file"

where verilog_license_file is the path to the Verilog-XL license file.

Solution B

The SNPSLMD_LICENSE_FILE or LM_LICENSE_FILE license environment 
variable is pointing to a Verilog-XL license file that is invalid or has expired. 
Examine the Verilog-XL output file verilog.log. Look for a line in the log file 
similar to this one:

Error! ERROR (LM -35): license for feature has expired.

If such an error is found, obtain a valid license file from Cadence Design 
Systems, install the license file, and set the license environment variable 
accordingly.

PROBLEM 6

When you invoke the Saber/Verilog software with the Verilog-XL simulator 
running on a remote host, the Verilog-XL simulator starts but exits immediately 
with the following error message:

The partner simulator exited unexpectedly

Solution A

There is no permission to execute the shell on the remote host. Verify that you 
have permission to execute an rsh command on the remote host by entering 
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% rsh host 'ls' (Sun machines)

% remsh host 'ls' (HP machines)

where host is the name of the remote host. If you are unable to execute a 
remote shell, contact your system administrator to arrange for you to execute 
remote shells on the remote host.

Solution B

The remote working directory is invalid. Verify that the working directory on the 
remote host is valid by entering

% rsh host 'cd remote_directory'

where host  is the name of the remote host, and remote_directory is the 
directory where the Verilog-XL simulator will be run on the remote host.

Correct the remote working directory as necessary to ensure a valid path name 
on the remote host, either by modifying the Saber Guide invocation command 
line (-pwd option) or by modifying the verilog.scf file (where the remote working 
directory can be specified).

Solution C

The Verilog-XL executable file cannot be found in the path on the remote 
system. Verify that the Verilog-XL executable file can be found on the remote 
system by entering

% rsh host 'cd remote_directory; verilog -s verilog_file'

where host is the name of the remote host, remote_directory is the directory 
where the Verilog-XL executable file will be run on the remote host, and 
verilog_file is the name of Verilog-XL input file.

Change permissions on the Verilog-XL executable file, or modify the path so 
that the Verilog-XL executable file can be found on the remote system.

The following sections describe:

Setting Up the Software to Use a Remote System

Installing the Frameway Integration for eProduct Designer
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Setting Up the Software to Use a Remote System

To set up your Saber/Verilog software to run on a remote system,

1. Set up a user account on the remote system. 

Your system administrator might need to do this for you.

2. Test that you can execute a remote shell locally.

• To test on an HP system, enter 

% remsh remote_host_name ls

• To test on other systems, enter 

% rsh remote_host_name ls

The following section describes:

Installing the Frameway Integration for eProduct Designer

Installing the Frameway Integration for 
eProduct Designer 

To complete the eProduct Designer Frameway installation, follow these steps: 

1. If it is not already installed, install the Mentor Graphics eProduct Designer 
software and verify the installation.

2. The Frameway software for eProduct Designer is installed at the same time 
you load Saber. Select the eProduct Designer option during installation.  

3. Copy the viewdraw.ini file, located in the 
install_home\Saber\framework\viewlogic\standard directory, to your 
%HOME% directory. 

4. Modify the Saber symbol path names in the viewdraw.ini file to be absolute 
path names. Replace the $(SABER_HOME) path name in each of the Saber 
symbol library path names with the actual path to the place where the Saber 
symbol files reside. 
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For example, if the location of install_home is 
c:\Synopsys\X-2005.09, change the symbol library path name from 

DIR [mr] $(SABER_HOME)/framework/viewlogic/symbols/beta  
(shr_beta)

to

DIR [rm] c:\Synopsys\X-
2005.09\Saber\framework\viewlogic\symbols\beta / 
  

(shr_beta) 

5. Modify the WDIR, PATH, and license environment variables as follows:

a. Start the System program by choosing Start > Settings > Control Panel 
> System > Environment tab. 

b. Add these paths to the WDIR variable: 

install_home\Saber\framework\viewlogic\standard 
install_home\ai_bin
install_home\Saber\bin

c. Add these paths to the PATH variable: 

install_home\ai_bin
install_home\Saber\bin

d. Modify the license environment variable (SNPSLMD_LICENSE_FILE or 
LM_LICENSE_FILE) to include the location of the Synopsys license 
file. You can use path or port@hostname syntax. For example,

27000@server1;C:/Synopsys/license.lic 

6. Verify that the Saber menu has been added to ViewDraw. 

a. Restart the eProductDesigner Dashboard. 

b. Open ViewDraw by clicking the ViewDraw icon. 

The Saber menu should be in the menu bar to the left of the Help menu.
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